過去ログ表示


過去ログ 34 を表示

トピック内全 6 記事中の 1 〜 6 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

MacOS X で XPI-install 不可?
(#4947) このトピック中1番目の投稿
■環境
MacOS X 10.2.4
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312

■設定
Mozilla - 環境設定... - Advanced - Scripts & Plugins の
Enable JavaScript for Navigator のチェックは入っている。

Mozilla - 環境設定... - Advanced - Software Installation の
Enable software installation. (You will be prompted for each 
update.) のチェックは入っている。

■現象
メニューの日本語化をしたくて http://plaza25.mbn.or.jp/~snip/ の
mozilla1.3-jajppack-tm0.2.xpi (JLP) をインストールしようとした。
Link for Install も、ダウンロードしたファイルを開くのも試した。
しかし、インストールされない。

いくつかのテーマをインストールしようとした。試したのは以下のもの。
http://mozilla.deskmod.com/core.mod?state=view&skin_id=28283
http://mozilla.deskmod.com/core.mod?state=view&skin_id=27066
しかし、インストールされない。

■補足
Windows98無印 では JLP もテーマも問題なくインストールできた。
Windows2000Pro では JLP は問題なし(テーマは試してないけど多分OK)。
同じ設定にしているはずなのに MacOS X 10.2.4 だけで発生している。

■推測
MacOS X 版は XPI-install script を処理できていないのではないか?
あるいは何らかの事情で機能を殺してたりするのかも(自信なし^^;;)。

同様の現象に遭遇された方はいらっしゃいませんか?


Re[1]: MacOS X で XPI-install 不可?
(#4949) このトピック中2番目の投稿

> ■環境
> MacOS X 10.2.4
> Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3) Gecko/20030312
>
> ■設定
> Mozilla - 環境設定... - Advanced - Scripts & Plugins の
> Enable JavaScript for Navigator のチェックは入っている。
>
> Mozilla - 環境設定... - Advanced - Software Installation の
> Enable software installation. (You will be prompted for each
> update.) のチェックは入っている。
>
> ■現象
> メニューの日本語化をしたくて http://plaza25.mbn.or.jp/~snip/
> mozilla1.3-jajppack-tm0.2.xpi (JLP) をインストールしようとした。
> Link for Install も、ダウンロードしたファイルを開くのも試した。
> しかし、インストールされない。
>
> いくつかのテーマをインストールしようとした。試したのは以下のもの。
> http://mozilla.deskmod.com/core.mod?state=view&skin_id=28283
> http://mozilla.deskmod.com/core.mod?state=view&skin_id=27066
> しかし、インストールされない。
>
> ■補足
> Windows98無印 では JLP もテーマも問題なくインストールできた。
> Windows2000Pro では JLP は問題なし(テーマは試してないけど多分OK)。
> 同じ設定にしているはずなのに MacOS X 10.2.4 だけで発生している。
>
> ■推測
> MacOS X 版は XPI-install script を処理できていないのではないか?
> あるいは何らかの事情で機能を殺してたりするのかも(自信なし^^;;)。
リリースノート( http://jt.mozilla.gr.jp/releases/mozilla1.3/ )にも
書いてありますが、MacOSXではXPInstallが一時的に無効にされています。
http://bugzilla.mozilla.org/show_bug.cgi?id=196959

リリースノートには、一度目を通してみてください。

Re[2]: MacOS X で XPI-install 不可?
(#4953) このトピック中3番目の投稿

> リリースノート( http://jt.mozilla.gr.jp/releases/mozilla1.3/ )にも
> 書いてありますが、MacOSXではXPInstallが一時的に無効にされています。

確かに書かれてました。(_ _)

ただ、原文が

On Mac OS X, XPInstall has been disabled for 1.3. This means that extensions and themes will not install for Mozilla 1.3 on Mac OS X.

ですから、和訳にある

Mac OS X では、XPInstall が 1.3 で無効になっています。これは、Mac OS X 版の Mozilla 1.3 に拡張機能やテーマをインストールできないためです。

というのは因果関係が逆になっていて、

Mac OS X では、XPInstall が 1.3 で無効になっています。これは、Mac OS X 版の Mozilla 1.3 に拡張機能やテーマをインストールできないことを意味します。

といったところでしょうか。無効になっているからインストールできないわけで。

#後半は和訳プロジェクトねたですね。(^^;;

済!
Re[3]: MacOS X で XPI-install 不可?
(#4954) このトピック中4番目の投稿

[修正2回]

http://plaza25.mbn.or.jp/~snip/ の release note に記載してみたのですが
よくよく考えると mozilla.org の release note に目を通して頂くのが最良な
気がしましたので、その旨を強調する形で ■ 掲載物について の部分に記載を
追記させて頂きました。m(__)m


Re[4]: MacOS X で XPI-install 不可?
(#4955) このトピック中5番目の投稿

XPInstallがダメでもファイルをしかるべき場所に手動でインストール
出来るはずですよ。例えばpinstripeなどはchromeフォルダにpinstripe.jar
をコピーする等です。

http://www.kmgerich.com/pinstripe/pinstripe.html

Re[5]: MacOS X で XPI-install 不可?
(#4960) このトピック中6番目の投稿

> XPInstallがダメでもファイルをしかるべき場所に手動でインストール
> 出来るはずですよ。例えばpinstripeなどはchromeフォルダにpinstripe.jar
> をコピーする等です。
>
> http://www.kmgerich.com/pinstripe/pinstripe.html

ものによってはインストールスクリプトを内蔵している
XPIパッケージもあり、そのスクリプトの処理内容に
よってはファイルを置くだけでは済まないこともありえます
のでご注意を。



このトピックの全ページ / [0]

返信不可


- Child Tree -