過去ログ表示


過去ログ 67 を表示

トピック内全 6 記事中の 1 〜 6 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

Java Appletが動きません。
(#10112) このトピック中1番目の投稿

Fedora Core 2とmozilla1.6/1.7を使っています。
サンのサイトから、java 1.4.2_5のSDK/JREをダウンロードし、プラグインモジュールのリンクを、mozillaディレクトリのpluginsディレクトリに張りました。
それで、試しにアプレット掲載のサイトにアクセスして試しているのですが、
http://java.sun.com/docs/books/tutorial/listofapplets.html
のアプレットは動きますが、
http://java.sun.com/products/plugin/1.4.2/demos/plugin/applets.html
のアプレットは動きません。
どうしてなのでしょうか。
 

Re[1]: Java Appletが動きません。
(#10117) このトピック中2番目の投稿
(環境: <EMBED
>
)

2004/08/17(Tue) 00:09:56 編集(投稿者)
2004/08/17(Tue) 00:04:13 編集(投稿者)

> http://java.sun.com/products/plugin/1.4.2/demos/plugin/applets.html
> のアプレットは動きません。

たぶん, IE(それともウインドーズ?)でしか動かないようになってるからです。(抜粋)
<OBJECT
classid =" clsid:CAFEEFAC-0014-0002-0000-ABCDEFFEDCBA"
WIDTH = 170 HEIGHT = 150 >
<PARAM NAME = CODE VALUE =" Clock.class" >
<COMMENT>


Re[2]: Java Appletが動きません。
(#10122) このトピック中3番目の投稿

seijunです。どうも有り難うございました。

> たぶん, IE(それともウインドーズ?)でしか動かないようになってるからです。(抜粋)

 アスキームックの「Linux for beginners 2004, Fedora Core 2 で始めるLinux」では、mozillaでアプレットが動いている写真が掲載されていました。
 しかし、記事で使ったJAVAのバージョンが1.4.2_04と古く、現在の1.4.2_05ではそぐわない箇所もあります。記事の通りに、JAVAのプラグインをインストールすると、mozillaが立ち上がりません。(^_^;)。ムックが発売された当時でしたら、JAVAのアプレットが動いたかも知れません。
 なお、Windows 2000だとJAVAのランタイムが違うと言って怒られますが、内部的に適合的なランタイムをセットするようで、別窓でアプレットは動きます。これが、mozillaでも動くと大変嬉しいのですが、ちょっと残念ですね。(;_;)。
&nbsp;

Re[3]: Java Appletが動きません。
(#10123) このトピック中4番目の投稿

こんばんは。

>> それに, 起動に失敗したときに, EMBED要素を使って もう一度トライしてるっぽいけど, COMMENT要素になってるから無効になってる気がするです。

実際に Clock.classと HTMLをダウンロードしてきて試してみたです。
COMMENTタグは (Mozillaとかでは)無効らしく, その中の EMBED要素は動く気配を見せてたです。んで, σ(^^) の環境では, バージョンの指定の部分を取り除いて type="application/x-java-applet" に直したら動きました。

雑誌に動いてる写真があるってことなので, バージョンが異なっているのか, あるいはソレまでと違って HTMLが変更されているか, どちらかだと思うです。

でも, sunには, もう少し正しい HTMLでアレして欲しいカモ。どーせツールでアレしてる訳だし。

(この↓ばーいだと, 一番外側の objectで表示できるから, embedの type属性がどっちであっても構わない)
<object codetype="application/java" classid="java:Clock.class" width=170 height=150>
 <OBJECT
  classid = "clsid:CAFEEFAC-0014-0002-0000-ABCDEFFEDCBA"
  codebase = "http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,0"
  WIDTH = 170 HEIGHT = 150 >
  <PARAM NAME = CODE VALUE = "Clock.class" >
  <PARAM NAME = "type" VALUE = "application/x-java-applet;jpi-version=1.4.2">
  <PARAM NAME = "scriptable" VALUE = "false">

  <COMMENT>
    <!-- type = "application/x-java-applet;jpi-version=1.4.2" \ -->
    <EMBED
      type = "application/x-java-applet" \
      CODE = "Clock.class" \
      WIDTH = 170 \
      HEIGHT = 150 \
      scriptable = false \
      pluginspage = "http://java.sun.com/products/plugin/index.html#download">
      <NOEMBED>
      alt="Your browser understands the &lt;APPLET&gt; tag but isn't running the applet, for some reason."
   Your browser is completely ignoring the &lt;APPLET&gt; tag!
      </NOEMBED>
    </EMBED>
  </COMMENT>
 </OBJECT>
</object>


Re[4]: Java Appletが動きません。
(#10124) このトピック中5番目の投稿

2004/08/17(Tue) 22:51:50 編集(投稿者)

さらに追記

○ type = "application/x-java-applet"
○ type = "application/x-java-applet;version=1.4.2"
× type = "application/x-java-applet;jpi-version=1.4.2"

about:plugins で現われる MIME Typeと一致しなきゃダメなんでしょね。

Re[5]: Java Appletが動きません。
(#10141) このトピック中6番目の投稿

seijunです。
> さらに追記
>
> ○ type = "application/x-java-applet"
> ○ type = "application/x-java-applet;version=1.4.2"
> × type = "application/x-java-applet;jpi-version=1.4.2"
>
> about:plugins で現われる MIME Typeと一致しなきゃダメなんでしょね。
どうも有り難うございました。「jpi-version」が良くなかったみたいですね。
そういえば、アプレットが表示されない画面で、マウスをクリックすると「jpiのバージョンが違う」などと怒られていたみたいです。
私も試してみます。
&nbsp;


このトピックの全ページ / [0]

返信不可


- Child Tree -