過去ログ表示


過去ログ 14 を表示

トピック内全 6 記事中の 1 〜 6 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

JavaVMの利用
(#1373) このトピック中1番目の投稿

初めて投稿します。

Windows2000+SP2、Mozilla1.0 RC3[BUILD ID 2002052306]+日本語パック1.1環境にて
Mozillaを使用しています。

So-netの提供しているハーボットというJavaプログラムがあるんですが、
SunのJavaプラグインでは動作できないので、なんとかならないかと思っています。
過去ログで検索したところ、「MicrosoftのJavaVMを使える」というような
記事を見かけたのですが、可能なのでしょうか?
また、その場合、どのように設定すれば良いのでしょうか?

Re[1]: JavaVMの利用
(#1375) このトピック中2番目の投稿

> 過去ログで検索したところ、「MicrosoftのJavaVMを使える」というような
> 記事を見かけたのですが、可能なのでしょうか?
> また、その場合、どのように設定すれば良いのでしょうか?

その過去ログはどれでしょう?

Mozilla の Javaサポートは OJIインタフェースに
基づくものなので、OJIをサポートした Java実行体が
必要になるかと思います。 Microsoft の Java実行体が
OJIサポートしているという話を私は聞いたことがありません。


Re[1]: JavaVMの利用
(#1376) このトピック中3番目の投稿

ケイさん、初めまして。

> So-netの提供しているハーボットというJavaプログラムがあるんですが、
> SunのJavaプラグインでは動作できないので、なんとかならないかと思っています。
> 過去ログで検索したところ、「MicrosoftのJavaVMを使える」というような
> 記事を見かけたのですが、可能なのでしょうか?
> また、その場合、どのように設定すれば良いのでしょうか?

MicrosoftのJavaVMを使用せずとも、SunのJavaプラグインで使用する事は可能です。現に私はハーボットその他のJavaプログラムが動作できています(Sun Java Plug-in 1.3.1_01にて確認。逆に少なくとも私の環境に於いては1.4.0では動作不可のようです)。

なお、私の環境につきましては、

OS : Windows2000 + SP2 + SRP1
Mozilla : 1.0 RC3 {Build ID: 2002052306} + RC3 JLP1.1
Java Plug-in : Sun Java Plug-in 1.3.1_01

となっております。

具体的な方法ですが、Windows2000+SP2でしたら私と同じなので、「Sun Java 1.3.1_01」がインストールされている環境に於いて、「C:\Program Files\JavaSoft\JRE\1.3.1\bin」より「NPOJI600.dll」というファイルを、「C:\Program Files\mozilla.org\Mozilla\Plugins」へとコピーしてください。

もしこれだけで使用できないようであれば、「C:\Program Files\JavaSoft\JRE\1.3.1\bin」にある「NPJava〜.dll」のファイルを同様に「C:\Program Files\mozilla.org\Mozilla\Plugins」へとコピーしてください。

あとは「設定」の「詳細」で「Javaを使用する」にチェックを入れれば使用できる事と思います。

私の環境に於いてはこれで動作ができました。お役に立てましたら幸いです。

Re[2]: JavaVMの利用
(#1674) このトピック中4番目の投稿

>私の環境に於いてはこれで動作ができました。お役に立てましたら幸いです。
 Sun Java 1.3.1_01インターナショナル版をインストールして
 同様の環境を作ってみましたが、動きませんでした。
 私はDドライブにMozillaをインストールしていますが、その程度のことは関係ないですよね?

>その過去ログはどれでしょう?
 「(#588) Re[5]: Mozilla 0.99素晴らしいのですが…」
 の過去ログなんですが、こちらの勘違いで内容を読み間違えていました。
 やっぱり、Javaプラグイン1.4.0ではHarbotは動かないみたいです、
 ご迷惑おかけしてすいませんでした。

Re[3]: JavaVMの利用
(#1681) このトピック中5番目の投稿

ケイさん、こんばんは。

>  Sun Java 1.3.1_01インターナショナル版をインストールして
>  同様の環境を作ってみましたが、動きませんでした。

すでに実施していらっしゃるのでしたら恐縮なのですが、Java1.4.0の「アプリケーションの追加と削除」からのアンインストール、およびMozillaの「Plug-in」フォルダよりJava1.4.0のプラグインを除去されてから1.3.1_01をインストールなさいましたでしょうか?

私の環境下ではJavaを1.3.1に変更した際に1.4.0が残ったままになっていると動作しませんでした。1.4.0を除去してから1.3.1_01を入れ直すと問題なく動作し始めましたので、やはり1.4.0が残っていたことが不具合を引き起こしていたように思われます。もし1.4.0を除去しないままで1.3.1_01をインストールされたのであれば、一旦1.4.0の本体とプラグインを除去してからインストールし直してみてください。

>  私はDドライブにMozillaをインストールしていますが、その程度のことは関係ないですよね?

もしすでに1.4.0を除去されたあとに1.3.1_01をインストールされているにもかかわらず動作しないようでしたら、インストールフォルダも疑ってかかった方がいいかもしれませんね。もし差し支えなければ、Mozillaを一旦アンインストールした後にデフォルトのインストールフォルダにインストールし直してから試してみることもお勧めいたします。

もしこれらを試しても直らないようであれば私が助言できることは無くなってしまいます。上記のいずれかにより直ればいいのですが。

Re[4]: JavaVMの利用
(#2079) このトピック中6番目の投稿

> すでに実施していらっしゃるのでしたら恐縮なのですが、Java1.4.0の「アプリケーションの追加と削除」からのアンインストール、およびMozillaの「Plug-in」フォルダよりJava1.4.0のプラグインを除去されてから1.3.1_01をインストールなさいましたでしょうか?
>
> 私の環境下ではJavaを1.3.1に変更した際に1.4.0が残ったままになっていると動作しませんでした。1.4.0を除去してから1.3.1_01を入れ直すと問題なく動作し始めましたので、やはり1.4.0が残っていたことが不具合を引き起こしていたように思われます。もし1.4.0を除去しないままで1.3.1_01をインストールされたのであれば、一旦1.4.0の本体とプラグインを除去してからインストールし直してみてください。

> もしすでに1.4.0を除去されたあとに1.3.1_01をインストールされているにもかかわらず動作しないようでしたら、インストールフォルダも疑ってかかった方がいいかもしれませんね。もし差し支えなければ、Mozillaを一旦アンインストールした後にデフォルトのインストールフォルダにインストールし直してから試してみることもお勧めいたします。
>
> もしこれらを試しても直らないようであれば私が助言できることは無くなってしまいます。上記のいずれかにより直ればいいのですが。
 返信が遅くなってしまってすいません。
 Taigaさんのおっしゃる通り、Javaプラグイン1.4.0をアンインストールした後、
 Javaプラグイン1.3.0_01をインストールしたのですが、動きませんでした…。
 (もっともハーボット自体、SunのJavaプラグインでは動作保証しない、と書いてありましたが(^^;)
 
 ちょっと残念だったんですが、ハーボットの次期バージョンがJavaアプレットから
 Flashに変更されたので、結果的にこの問題は、わたし個人にはあまり大きな
 問題ではなくなってしまいました…(^^;
 
 Taigaさん、tamcatさん親切に下さいまして、どうもありがとうございました。
済!

このトピックの全ページ / [0]

返信不可


- Child Tree -