過去ログ表示


過去ログ 11 を表示

トピック内全 11 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

XML+XSLについて
(#1538) このトピック中1番目の投稿

Windows XP
Mozilla 1.0 (build ID:2002053012)

初めまして。
Mozillaを使い始めたばかりのもです。

先日より、XML+XSLを使おうと思いましたが、
試しに作ってみたところ表示されません。
設定はほぼ初期のままで、日本語化パッチを当てたのみです。

Mozillaでは表示できないのでしょうか?
一応対応しているとの表記がありますが・・・。
よろしくお願いします。

Re[1]: XML+XSLについて
(#1539) このトピック中2番目の投稿

> 初めまして。
> Mozillaを使い始めたばかりのもです。

takaさん、はじめまして。

> 先日より、XML+XSLを使おうと思いましたが、
> 試しに作ってみたところ表示されません。
> 設定はほぼ初期のままで、日本語化パッチを当てたのみです。

ちなみに、Language and Web content はあとから切り替えられますので、
Mozillaの場合はパッチというよりはパックと書いた方がよさそうです。
(編集 -> 設定 -> 表示 -> 言語/コンテンツ でもそう訳されています)
ご参考までに(^-^)

> Mozillaでは表示できないのでしょうか?
> 一応対応しているとの表記がありますが・・・。
> よろしくお願いします。

IEでは表示できる、ということでしたら、
http://www.mozilla.org/projects/xslt/index.html#faq
を見てみて下さい。ネームスペースの指定などを
適切にすれば、思った通りに動作するかも知れません。

それでも動かない場合には、どのようにしたのに
動かなかったのかをもう少し書いて下されば、他の方から
アドバイスがもらえるかも知れません。

このページの和訳版
http://jt.mozilla.gr.jp/projects/xslt/index.html
は、内容がアップデートされていないようです。
作業して下さる方は私にメールをください。m(_ _)m



Re[2]: XML+XSLについて
(#1541) このトピック中3番目の投稿

> このページの和訳版
> http://jt.mozilla.gr.jp/projects/xslt/index.html
> は、内容がアップデートされていないようです。
> 作業して下さる方は私にメールをください。m(_ _)m

アドレスが非表示になってました。
kambe@mc.kcom.ne.jp
です。


Re[1]: XML+XSLについて
(#1542) このトピック中4番目の投稿

Re: XML+XSLについて
(#1545) このトピック中5番目の投稿

おそらくShift_JISで作ってると思うんですが、
とりあえず、UTF-8に変えて試してみたらどうでしょうか。


Re[1]: XML+XSLについて
(#1549) このトピック中6番目の投稿

早速のレス、ありがとうございます。

Ryuzi Kambeさんの教えていただいたアドレスから飛んだところの
サンプルを参考に修正したらなんとか表示されました^^
本当にありがとうございました〜。

名無しさん、Bさん、情報提供ありがとうございます♪
早速参考にさせていただきました。
エンコードに関しては”UTF-8”でも同じだったんです(涙)

でもホントありがとうございました^^

Re[1]: XML+XSLについて
(#1602) このトピック中7番目の投稿

便乗します。すみません。

XSLスタイルシートのファイル名を絶対パスで指定するとうまくいかない(固まる)ようなのですが、これについてどなたかご存知でしょうか?

<?xml-stylesheet type="text/xsl" href="hoge.xsl"?> ←これはOK
<?xml-stylesheet type="text/xsl" href="xxx/hoge.xsl"?> ←これもOK

<?xml-stylesheet type="text/xsl" href="/xxx/hoge.xsl"?> ←これはNG

http://www.mozilla.gr.jp/docs/beginmoz-1.0/feature-navigator.html#navigator-feature-xslt
にあるサンプルでも試しました。


Re[2]: XML+XSLについて
(#1604) このトピック中8番目の投稿

フリーズするというのならば、おそらく /xx/style.xsl へ
アクセスしたときに返ってくる http Content-type フィールドの
Media typeが text/xml と application/xml のどちらでも
ないのではないかと思います。 XSLT Ver1.0 では text/xml か
application/xmlのいずれかとされていますので、テストに使った
XML/XSLT の場合に返ってくる Content-type を調べてみて下さい。

試しに
http://www02.so-net.ne.jp/~tamcat/mozilla/begin-moz/1.0/samples/xslt-sample-tmp.xml
へアクセスしてください。この XMLには
<?xml-stylesheet type="text/xsl" href="/~tamcat/xslt-sample-tmp.xsl"?>
と記述しています。 次に URL欄に about:cache?device=disk と
タイプしてからそこに表示されたキャッシュエントリの中から
http://www02.so-net.ne.jp/~tamcat/xslt-sample-tmp.xsl
探してください。 そのリンクをクリックすると Media type などの
情報を参照することができます。


#この辺りは手元の「はじめての Mozilla 1.0」最新版には書いている
#のですが、まだ公開してない版なもので。すみません。


Re[3]: XML+XSLについて (Web-Sniffer)
(#1607) このトピック中9番目の投稿

> フリーズするというのならば、おそらく /xx/style.xsl へ
> アクセスしたときに返ってくる http Content-type フィールドの
> Media typeが text/xml と application/xml のどちらでも
> ないのではないかと思います。 XSLT Ver1.0 では text/xml か
> application/xmlのいずれかとされていますので、テストに使った
> XML/XSLT の場合に返ってくる Content-type を調べてみて下さい。

この間Bugzilla-JPの報告の中で教えてもらったのですが、
http://webtools.mozilla.org/web-sniffer/
で、HTTP Header等を簡単にチェックできます。
便利です。

Re[3]: XML+XSLについて
(#1609) このトピック中10番目の投稿

> フリーズするというのならば、おそらく /xx/style.xsl へ
> アクセスしたときに返ってくる http Content-type フィールドの
> Media typeが text/xml と application/xml のどちらでも
> ないのではないかと思います。 XSLT Ver1.0 では text/xml か
> application/xmlのいずれかとされていますので、テストに使った
> XML/XSLT の場合に返ってくる Content-type を調べてみて下さい。

おっしゃる通り、MediaTypeがtext/xslになっていました。
サーバの設定をtext/xmlに変更したところ、動くようになりました。
ありがとうございます。



[ 次のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -