過去ログ表示


過去ログ 118 を表示

トピック内全 3 記事中の 1 〜 3 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

extensionがチェコ語?でインストールされてしまう
(#19028) このトピック中1番目の投稿
(環境: Linux/Firefox1.0)

2005/04/21(Thu) 02:52:09 編集(投稿者)

Vine Linux 3.1でFirefox1.0.3を使っています。
=====================================
$ uname -a
Linux 2.4.27-0vl7 #1 2004年 10月 27日 水曜日 13:30:16 JST i686 unknown
=====================================
Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
=====================================

[ツール]->[拡張機能]->[新しい拡張機能を入手]でhttps://addons.update.mozilla.org/からextensionをダウンロード、インストールし、これを有効にするためFirefoxを終了->再起動しても、日本語でも英語でもない言語(チェコ語?)でインストールされてしまい、設定できずに困っています。(どのエクステンションをインストールしても同じことが起こります)
Firefox側の言語は優先順に日本語[ja]->英語/アメリカ合衆国[en-us]->英語[en]に設定してあります。

1.0.0リリースの時からずっと同じ状況ですので、バージョン依存の問題ではないと思います。

原因はどこにあるのでしょうか?
よろしくお願いします。

(環境: その他/その他)

# Vineゆーざーでは有りませんし、ちょっとしたツッコミなので流して下さい....(^^)

> Vine Linux 3.1でFirefox1.0.3を使っています。
ディスクトップ環境の言語は何ですか EUCですか?
判断された「チェコ語?って」読めますか? 単にディスクトップ環境のフォントサーバー絡みって事は有りませんか?
セーフモードで起動しても傷害が残りますか?

> 1.0.0リリースの時からずっと同じ状況ですので、バージョン依存の問題ではないと思います。
他のディストリでも拡張の傷害を経験していますしバグジラ送りも有ります、発展途中ですから....(^^)。
mozilla.org以外で検証されてないor作成された、拡張自体の採用を辞めた運用は如何でしょうか、拡張自体の不具合は配布側に問い合わせるのが筋とも思います。

多くはプロファイル切り替えや設定のテキスト編集やabout:configでの変更でトラブルを抱えるより、十分にまかなえるとは思っています。
Mozilla系の編集はUTF8エディターです。

(環境: Linux/Firefox1.0.3)

> # Vineゆーざーでは有りませんし、ちょっとしたツッコミなので流して下さい....(^^)

ありがとうございます。
その後検証の為インストールしたことがない拡張もいくつか試して見たところ、ちゃんと英語でインストールされるものもあることがわかりました。
(もっとも多言語サポートされてないだけかもしれませんが^^;)

> ディスクトップ環境の言語は何ですか EUCですか?

念の為GNOME起動時に言語に英語を指定してやってみましたが、やっぱり同様の事象が再現しました。

> 判断された「チェコ語?って」読めますか? 単にディスクトップ環境のフォントサーバー絡みって事は有りませんか?

一応読めてます。単語の綴りからチェコ語と判断しました。
Linuxをデスクトップとして使い始めたのは最近なので不勉強ですが,xfsは以下のフォントをロードできるようです。
=========================================================
# chkfontpath --list
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/japanese:unscaled
2: /usr/X11R6/lib/X11/fonts/misc:unscaled
3: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/japanese
8: /usr/X11R6/lib/X11/fonts/misc
9: /usr/X11R6/lib/X11/fonts/freefont
10: /usr/X11R6/lib/X11/fonts/CID
11: /usr/X11R6/lib/X11/fonts/TTF
12: /usr/X11R6/lib/X11/fonts/TrueType
13: /usr/X11R6/lib/X11/fonts/75dpi
14: /usr/X11R6/lib/X11/fonts/100dpi
15: /usr/X11R6/lib/X11/fonts/cyrillic
16: /usr/share/fonts/default/Type1
17: /usr/X11R6/lib/X11/fonts/latin2/Type1
18: /usr/share/AbiSuite/fonts
=========================================================

> セーフモードで起動しても傷害が残りますか?

# firefox -safe-mode だと拡張機能自体を切り離して起動するようで、問題の切り分けにはなりませんでした。

> mozilla.org以外で検証されてないor作成された、拡張自体の採用を辞めた運用は如何でしょうか、拡張自体の不具合は配布側に問い合わせるのが筋とも思います。

確かに。今のところ差し迫って支障もないのでそのようにしたいと思います。

> about:configでの変更

おー。これで変数の変更できるんですね。

結局原因はよくわかりませんでしたが、いろいろ勉強になりました。
ありがとうございました。



このトピックの全ページ / [0]

返信不可


- Child Tree -