過去ログ表示


過去ログ 160 を表示

トピック内全 10 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

UserAgentSwitcher0.6.7でエラー
(#25173) このトピック中1番目の投稿
(環境: WinXP SP2/Firefox1.0.6)

機能拡張の更新で「UserAgentSwitcher0.6.7」があったので更新したら、
再起動後、画面のステータスバー下に以下のメッセージが表示されます

<menu accesskey="&useragentswitcher.key;" id="useragentswitcher-menu" insertbefore="prefSep"
label="&user---------^

又、ツール-機能拡張から「User Agent Switcher0.6.7」の設定でもエラーが表示されます

XML パースエラー:定義されていない実体が使用されています
URL:chrome://useragentswitcher/content/options/options.xul
行番号:10,列番号:16:

title="&useragentswitcher.options.title;"

又その影響か右側のスクロールバーが表示されません。

Win XP Pro
Firefox1.0.6
infoRSS0.8.9.4
TabMix0.2.2.3
Translate0.6.0.7
ShowImage0.3
Popup ALT Attribute1.3
adblock v5 d2
Irvine ContextMenu0.2
IE View1.2.5
Plain Text Links0.2

Re[1]: UserAgentSwitcher0.6.7でエラー
(#25175) このトピック中2番目の投稿
(環境: Win2000/Firefox1.0.7)

> 機能拡張の更新で「UserAgentSwitcher0.6.7」があったので更新したら、
> 再起動後、画面のステータスバー下に以下のメッセージが表示されます
 セーフモードでFirefoxを起動して、「UserAgentSwitcher0.6.7」を一旦削除し、ダウンロードしたxpiファイルをドラッグアンドドロップしてインストールしてください。(自動更新は、まだまだうまく動かないことがあるためです)

Re[2]: UserAgentSwitcher0.6.7でエラー
(#25178) このトピック中3番目の投稿
(環境: WinXP SP2/Firefox1.0.6)

ありがとうございます

>  セーフモードでFirefoxを起動して、「UserAgentSwitcher0.6.7」を一旦削除し、ダウンロードしたxpiファイルをドラッグアンドドロップしてインストールしてください。(自動更新は、まだまだうまく動かないことがあるためです)

忘れていましたが、以前にも同様の不具合があったことを思い出し、
・アンインストール
http://firefox.geckodev.org/?User%20Agent%20Switcherより
 「useragentswitcher_0.6.7_jp.xpi」をDLし
・ドラッグアンドドロップで追加したら
「正常」になりました。

>自動更新は、まだまだうまく動かないことがあるためです
参考のためにお聞きしますが…
「全ての拡張機能」で起きる可能性があるのでしょうか?

Re[3]: UserAgentSwitcher0.6.7でエラー
(#25179) このトピック中4番目の投稿
(環境: Win2000/Firefox1.0.7)

> ・http://firefox.geckodev.org/?User%20Agent%20Switcherより
>  「useragentswitcher_0.6.7_jp.xpi」をDLし
> ・ドラッグアンドドロップで追加したら
> 「正常」になりました。
よかったです。
>
> >自動更新は、まだまだうまく動かないことがあるためです
> 参考のためにお聞きしますが…
> 「全ての拡張機能」で起きる可能性があるのでしょうか?
いや、そんなに拡張しないので分からないですけど、よく自動で更新するとトラブルがというのを聞くので…(実際にタブブラウザ拡張をその手順でUpdateしたら同じようなエラーに遭遇したし…という経験上の話です)

Re[3]: UserAgentSwitcher0.6.7でエラー
(#25180) このトピック中5番目の投稿
(環境: WinXP SP2/Firefox1.5b)

> ありがとうございます
>
>> セーフモードでFirefoxを起動して、「UserAgentSwitcher0.6.7」を一旦削除し、ダウンロードしたxpiファイルをドラッグアンドドロップしてインストールしてください。(自動更新は、まだまだうまく動かないことがあるためです)
>
> 忘れていましたが、以前にも同様の不具合があったことを思い出し、
> ・アンインストール
> ・http://firefox.geckodev.org/?User%20Agent%20Switcherより
>  「useragentswitcher_0.6.7_jp.xpi」をDLし
> ・ドラッグアンドドロップで追加したら
> 「正常」になりました。
>
> >自動更新は、まだまだうまく動かないことがあるためです
> 参考のためにお聞きしますが…
> 「全ての拡張機能」で起きる可能性があるのでしょうか?

上書き互換性がない場合があるので、すべての拡張で起きる可能性はあるでしょう。しかし、とりあえずアップデートする前にインフォメーションくらいは読みましょう。上書き互換性がない場合大抵書いてあります。

今回もUserAgentSwitcherのHPに「 If you are upgrading the extension uninstall the original version before upgrading. 」(もしこの拡張をアップデートする場合、アップデートする前にオリジナルバージョンをアンインストールしてください)と、きちんと書いてあります。

Re[4]: UserAgentSwitcher0.6.7でエラー
(#25181) このトピック中6番目の投稿
(環境: WinXP SP2/IE6)

わかりました。注意します。

ありがとうございました。

Re[4]: UserAgentSwitcher0.6.7でエラー
(#25183) このトピック中7番目の投稿
(環境: WinXP SP2/IE6)

>(もしこの拡張をアップデートする場合、アップデートする前にオリジナルバージョンをアンインストールしてください)と、きちんと書いてあります。
今まで全然意識していませんでした。

拡張機能の更新がある場合、無条件で更新してました。

ん〜なかなかFirefoxのHPの見方に慣れない…というか難しいですね(^_^;)

今後は意識してみたいと思います。

ご教授ありがとうございました。

Re[1]: UserAgentSwitcher0.6.7でエラー
(#25184) このトピック中8番目の投稿
(環境: WinXP SP2/IE6)

>とおやまさん
>SSKさん

お陰さまで「解決」いたしました。

ありがとうございました。
済!
Re[4]: UserAgentSwitcher0.6.7でエラー
(#25185) このトピック中9番目の投稿
(環境: WinXP SP2/Firefox1.5b)

>>>自動更新は、まだまだうまく動かないことがあるためです
>>参考のためにお聞きしますが…
>>「全ての拡張機能」で起きる可能性があるのでしょうか?
> いや、そんなに拡張しないので分からないですけど、よく自動で更新するとトラブルがというのを聞くので…(実際にタブブラウザ拡張をその手順でUpdateしたら同じようなエラーに遭遇したし…という経験上の話です)

自分もあくまで経験上の話ですが、
拡張の上書きインストールがうまくいっていないのであって、
自動更新かどうかには直接は関係ないと思います。
自動更新でダメなものは、手動で上書きインストールしてもやっぱりダメです。

Re[5]: UserAgentSwitcher0.6.7でエラー
(#25189) このトピック中10番目の投稿
(環境: Linux/seamonkey1.0a)

Firefox拡張は各作者がバラバラに作っているので、どうしても不整合が起きることになります。

正直、いつまでも仕様を固めない本体の開発陣はどうかと思う。これじゃ、安心して普及に努められない。ユーザーに一々プロファイルがどうのこうの、なんて説明するのはおかしい。

#単なる愚痴


このトピックの全ページ / [0]

返信不可


- Child Tree -