過去ログ表示


過去ログ 181 を表示

トピック内全 5 記事中の 1 〜 5 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

TB1.5でドメイン省略時にメール送信できない
(#28471) このトピック中1番目の投稿
(環境: WinXP SP2/Firefox1.5)

先日、TB1.0.7から1.5にバージョンアップしたところ、それまでローカル
アドレスにメール送信する際に、@以下なしで可能だったのが
「**** は user@host 形式になっておらず、有効なメールアドレスでは
 ありません。メールを送信する前に修正してください。」
というアラートが出て、送信することができなくなりました。
UIでは設定するところが特に見当たらないのですが、どなたか回避方法を
ご存じではないでしょうか?
ちなみに、拡張機能として Enigmail0.94.0+LanguagePack を入れており
OSは WinXP SP2 です。
ご教授よろしくお願いします。

Re[1]: TB1.5でドメイン省略時にメール送信できない
(#28476) このトピック中2番目の投稿
(環境: WinXP SP2/Firefox1.6a)

2006/01/17(Tue) 19:27:39 編集(投稿者)

> 先日、TB1.0.7から1.5にバージョンアップしたところ、それまでローカル
> アドレスにメール送信する際に、@以下なしで可能だったのが
> 「**** は user@host 形式になっておらず、有効なメールアドレスでは
>  ありません。メールを送信する前に修正してください。」
> というアラートが出て、送信することができなくなりました。
> UIでは設定するところが特に見当たらないのですが、どなたか回避方法を
> ご存じではないでしょうか?


単純にフルアドレスにすればよろしいのでは?

Re[1]: TB1.5でドメイン省略時にメール送信できない
(#28478) このトピック中3番目の投稿
(環境: Win2000/seamonkey1.0a)

> 先日、TB1.0.7から1.5にバージョンアップしたところ、それまでローカル
> アドレスにメール送信する際に、@以下なしで可能だったのが
> 「**** は user@host 形式になっておらず、有効なメールアドレスでは
>  ありません。メールを送信する前に修正してください。」
> というアラートが出て、送信することができなくなりました。

Bug-org 93453による、仕様変更かな?
https://bugzilla.mozilla.org/show_bug.cgi?id=93453
2005-05-07にFIXEDになっていますから、1.0.7と1.5で違う、ということも頷けます。
Autocompleteのオン・オフでどう変わるのかとかは、詳しく読んでいないので不明です。
mail.autoComplete.highlightNonMatches=true/falseは、色を赤にするかそうでないかの違いっぽいんですが。

Re[2]: TB1.5でドメイン省略時にメール送信できない
(#28483) このトピック中4番目の投稿
(環境: WinXP SP2/Firefox1.5)

まつです。

Wadaさん、palさん早速のレスありがとうございます。

Wadaさん:
> Bug-org 93453による、仕様変更かな?
> https://bugzilla.mozilla.org/show_bug.cgi?id=93453
> 2005-05-07にFIXEDになっていますから、1.0.7と1.5で違う、という
> ことも頷けます。

なるほど、、、
マルチアカウントが実装されたときに、デフォルトドメインを
どうやって管理するか、というのが議論になってたのですね。

> Autocompleteのオン・オフでどう変わるのかとかは、詳しく読んで
> いないので不明です。
> mail.autoComplete.highlightNonMatches=true/falseは、色を赤に
> するかそうでないかの違いっぽいんですが。

はい、アドレス帳にマッチしたものがあれば色が変わるだけの
スイッチのようです。

で、色々試してみたのですが、ご指摘のとおり
mail.enable_autocomplete=true にすると、アドレス帳にない場合は
デフォルトのドメインが補完されることがわかりました。

私はアドレス帳は使わないので、これで、一応意図するふるまいと
同等のことができることがわかりました。

palさん:
> 単純にフルアドレスにすればよろしいのでは?

実は、社内メールの誤送信対策として、社内ではドメインを付けずに
送信するルールとなっているんです。
#MTAが判断して補完しています

ということで、解決できました。
ありがとうございました m(_ _)m
済!
Re[3]: TB1.5でドメイン省略時にメール送信できない
(#28503) このトピック中5番目の投稿
(環境: WinXP SP2/Firefox1.5)

すみません、自己レスです。

> で、色々試してみたのですが、ご指摘のとおり
> mail.enable_autocomplete=true にすると、アドレス帳にない場合は
> デフォルトのドメインが補完されることがわかりました。

これだけではどうも足りないようで

mail.identity.default.autocompleteToMyDomain=true

も設定しないといけませんでした。
#デフォルト値は falseでした・・・
済!

このトピックの全ページ / [0]

返信不可


- Child Tree -