過去ログ表示


過去ログ 20 を表示

トピック内全 3 記事中の 1 〜 3 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

Mozillaのメーラーの不具合について報告です
(#2918) このトピック中1番目の投稿

いつもお世話になっております。

以前、メーラーの不具合で質問させていただいたのですが、原因が
分かりましたので報告いたします。このメーラーの不具合は、アカ
ウント名の下のツリービューが表示されなくなり、使用不可になっ
てしまうというものです。この現象は、メールアカウントを設定した
後のメーラーの再起動後に発生します。

原因は、OS(Windows2000/XP)の使用者名を2byte文字にしていた
場合に、メールを保存するローカルディレクトリを読みに行けなく
なる事によるようです。使用者名を日本語などに設定していると、
この現象が発生し、Mozillaメーラーが使えない可能性があると思
います。

回避法としましては、「Mail&Newsgroupsアカウント設定」内の
「サーバ設定」の「ローカルディレクトリ」を、2byte文字が入ら
ない別のパスに移す処置が考えられます。私はこの方法で解決し
ました。

以上、すでにさんざん知られている内容かも知れませんが、何かの
お役に立ちましたら幸いです。それでは失礼します。


> 原因は、OS(Windows2000/XP)の使用者名を2byte文字にしていた
> 場合に、メールを保存するローカルディレクトリを読みに行けなく
> なる事によるようです。使用者名を日本語などに設定していると、
> この現象が発生し、Mozillaメーラーが使えない可能性があると思
> います。
>
> 回避法としましては、「Mail&Newsgroupsアカウント設定」内の
> 「サーバ設定」の「ローカルディレクトリ」を、2byte文字が入ら
> ない別のパスに移す処置が考えられます。私はこの方法で解決し
> ました。

Win-Me/Mozilla 1.2Alpha/新規プロファイルの環境で、現象を確認できました。

「Mail&Newsgroupsアカウント設定」内の「サーバ設定」の「ローカルディレクトリ」を、
「C:\WINDOWS\...\Mail\漢字」に変更したら、
pref.jsの中身のその部分は「"C:\\WINDOWS\\...\\Mail\\\"W"」となって、化けていました。
「Mail&Newsgroupsアカウント設定」で見ても「ちゃんと」化けています(^^)
そのため、ディレクトリーが見つからないようです。

なお、pref.jsを無理やり「"C:\\WINDOWS\\...\\Mail\\漢字"」と書き換えると、
漢字部分はエラーとみなされるのか無視され「"C:\\WINDOWS\\...\\Mail"」に変えられてしまい、
その結果、Mailディレクトリー以下が全部表示されました。

問題がおこるのは、OS側の設定ですと、Win-NT/2000/XPで「使用者名」に日本語を使った場合ですね。
「c:\Documents and Settings\使用者名\...\Mozilla\Profiles\...\Mail\...」とかになるので、必ず起こりそうです。
じゃがいも男爵さんが、Win-NT系で、日本語の使用者名で、Mozillaのメールを使った、世界最初のユーザー、ということになりますね(^^)
問題が起こった時のpref.jsの中身を見ると、状況がはっきりすると思います。

Mozilla側の設定ですと、
Mozilla 1.1Alphaではアカウントに対応するディレクトリー名は、
アカウント名やユーザー名ではなく、サーバー名になったので、
「ローカルディレクトリ」部分に2バイト文字が使われる可能性は、
(1) プロファイル名に2バイト文字を使った場合
(2) 2バイト文字を含むメールサーバー名が実際に使用されている場合、
(3) メールの管理のために、サーバー名に2byte文字を含む(ダミーのサーバーの)アカウントを設定した場合、
(4)「Mail&Newsgroupsアカウント設定」内の「サーバ設定」の「ローカルディレクトリ」で、2byte文字を指定した場合、
の場合だけだと思います。
今まで誰もやらなかったんでしょうね。

Bagzilla-JPに問題報告をしたほうがいいでしょう。

(追記、2002/9/13 20:55)
Bugzilla-JPのバグ 2635 をオープンしました。
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2635
もじら組BBSの方は、解決済み、にしておきます。
済!

>>原因は、OS(Windows2000/XP)の使用者名を2byte文字にしていた
>>場合に、メールを保存するローカルディレクトリを読みに行けなく
>>なる事によるようです。使用者名を日本語などに設定していると、
>>この現象が発生し、Mozillaメーラーが使えない可能性があると思
>>います。
(中略)
>
> 問題がおこるのは、OS側の設定ですと、Win-NT/2000/XPで「使用者名」に日本語を使った場合ですね。
> 「c:\Documents and Settings\使用者名\...\Mozilla\Profiles\...\Mail\...」とかになるので、必ず起こりそうです。
> じゃがいも男爵さんが、Win-NT系で、日本語の使用者名で、Mozillaのメールを使った、世界最初のユーザー、ということになりますね(^^)

WinOSにおける非ascii文字ユーザ名の問題は、その昔はリリースノートに
書いてあった問題なのですが、途中から書かれなくなりました。 たとえば
http://jt.mozilla.gr.jp/releases/mozilla0.9.9/index.html#internationalの「全般とプロファイルマネージャ」の冒頭とか。

1.0rc1から記述がなくなったので処置されたのかと思っていましたが。


済!

このトピックの全ページ / [0]

返信不可


- Child Tree -