過去ログ表示


過去ログ 20 を表示

トピック内全 11 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

複数バージョンの起動
(#2971) このトピック中1番目の投稿

1.1のリリース以降、1.x系列と1.0系列の複数バージョンをインストール
しています(現在、1.0.1と1.1)。
私のニーズとしては、一つのプロファイルを共有したいのですが、
トラブルの元だということなので、プロファイル名1.0.1と1.1を用意し、
起動時にプロファイルマネージャにて選択・起動してます。

お伺いしたいのは、1.1アイコンクリックで1.1起動時には、
プロファイルマネージャを開くことなく問答無用でプロファイル1.1を用いて
mozillaを起動、1.0.1も然り、としたいのですが、それは無理なのでしょうか。
イメージとしては、アイコン(あるいは、プログラム本体)とプロファイルを
関連付けてしまう、ということになるでしょうか。

環境は、WindowsXP(HOME), mozilla1.0.1, mozilla1.1
よろしくお願いします。


Re[1]: 複数バージョンの起動
(#2975) このトピック中2番目の投稿

http://member.nifty.ne.jp/tamcat/mozilla/begin-moz/1.0/profilemanager.html#profilemanager-multiprofile
の「Mozilla の起動引数でプロファイルを指定して起動する」に書いてあります。
具体的には

"C:\Program Files\mozilla.org\Mozilla1.0\mozilla.exe" -P 1.0.1
"C:\Program Files\mozilla.org\Mozilla\mozilla.exe" -P 1.1

見たいな感じのショートカットをつくればいいです。



Re[1]: 複数バージョンの起動
(#2978) このトピック中3番目の投稿

> 1.1のリリース以降、1.x系列と1.0系列の複数バージョンをインストール
> しています(現在、1.0.1と1.1)。
> (中略)
> お伺いしたいのは、1.1アイコンクリックで1.1起動時には、
> プロファイルマネージャを開くことなく問答無用でプロファイル1.1を用いて
> mozillaを起動、1.0.1も然り、としたいのですが、それは無理なのでしょうか。

プロファイルの指定方法については風の歌さんが答えていらっしゃるので、その場合の注意点を。

複数バージョンのMozillaは同時に起動できない可能性が高いことにご注意ください。

Win-MEの環境ですが、私はZIPバージョンを使用しているのでレジストリーが共通のためか、Quick Launchを立ち上げていなくても、「PROFILE-1-2a」で立ち上げたMozilla 1.2Alphaがすでにいると、-P "PROFILE-1-0-1"を指定したMozilla 1.0.1のショートカットをクリックしても、 プロファイルマネージャーを経由せず「PROFILE-1-2a」のMozilla 1.2Alphaの新しいウィンドウが立ち上がります。
Netscape 7.0の英語版と日本語版は別のディレクトリーに導入していますが、こちらも同様にプロファイルマネージャーに入らず、そのまますでに動いている方になります。
すでにMozillaがいると、それがQuick Launchと同様に働いているように見えます。
Mozillaのインストーラー版だと問題ないかもしれませんが、念のため。

私はTab Extentionsというxpi(XULアプリケーション)のあるMozillaとないMozillaでプログラムディレクトリーをわけているのですが、TabExtentionsなしのMozillaが立ち上がっているのにTab Extentionあり用のショートカットから立ち上げて、導入するつもりのない方に導入してしまうことを何度もやりました(^^;
複数のプロファイルがあるので、最初の起動かどうかはプロファイルマネージが立ち上がるかどうかでわかるにも関わらずです(<=アホ、注意力散漫)。
杞憂だとは思いますが、プロファイルマネージャーが上がらない場合、テーマなどを変えて一目で区別つくとかしないと、誤った問題報告につながりかねないので、その点にご注意ください。

Re[1]: 複数バージョンの起動
(#2992) このトピック中4番目の投稿

風の歌さん、wadaさん、アドバイスありがとうございます。
私の場合、1.1はインストーラ版、1.0.1はZIPを利用しています。
(今使っているのは2台めのPCで、nightlyのみインストール)
方法については風の歌さんのご説明でよく分かりましたが、
wadaさんのアドバイスについて、今回のケースを例にしますと、
1.1と1.0.1双方とも、インストーラ版を利用すれば、wadaさんご指摘の問題は
回避できる、と考えてよいのでしょうか?
と言いますのは、「安全なもじらの飼い方」での説明によると、
http://cgi22.plala.or.jp/simpleli/text/tech/020220mozilla/020312mozillaZip.html
インストーラとZIPの違いについて、複数バージョンについて基本的にNG、
ZIPはインストするディレクトリを変えることによりOKとなっており、
少々混乱しております。
お手数ですが、この点について、ご確認いただけますでしょうか。
よろしくお願いします。

#もしかして、とてつもない勘違いしてる気もするのですけど。。。^^;;


Re[2]: 複数バージョンの起動
(#3000) このトピック中5番目の投稿

> 私の場合、1.1はインストーラ版、1.0.1はZIPを利用しています。
> wadaさんのアドバイスについて、今回のケースを例にしますと、
> 1.1と1.0.1双方とも、インストーラ版を利用すれば、wadaさんご指摘の問題は
> 回避できる、と考えてよいのでしょうか?

わたくしメは、ウインドウズ2000に、 Wazilla-1.0 と Mozilla-1.1 とを、
共にインストーラ版でインストして使っておりますが、残念ながら、
wada さん同様、同時に使うことは出来ません。
複数ヴァージョンを同時使用できればホント便利なんですけどね^^。

ちなみに、上の、どちらかとネスケ7とは同時使用可能です。

> と言いますのは、「安全なもじらの飼い方」での説明によると、
> http://cgi22.plala.or.jp/simpleli/text/tech/020220mozilla/020312mozillaZip.html
> インストーラとZIPの違いについて、複数バージョンについて基本的にNG、
> ZIPはインストするディレクトリを変えることによりOKとなっており、
> 少々混乱しております。

インストーラ版によるインストも、ヴァージョン毎にインスト先と
プロファイルとを別々にしておけば、インスト自体は、「基本的にNG」
ということは無いと思いますよ。

答えになってなければ、ゴメンナサイね(ハート)。


Re[2]: 複数バージョンの起動
(#3001) このトピック中6番目の投稿

> 風の歌さん、wadaさん、アドバイスありがとうございます。
> 私の場合、1.1はインストーラ版、1.0.1はZIPを利用しています。
> (今使っているのは2台めのPCで、nightlyのみインストール)
> 方法については風の歌さんのご説明でよく分かりましたが、
> wadaさんのアドバイスについて、今回のケースを例にしますと、
> 1.1と1.0.1双方とも、インストーラ版を利用すれば、wadaさんご指摘の問題は
> 回避できる、と考えてよいのでしょうか?
> と言いますのは、「安全なもじらの飼い方」での説明によると、
> http://cgi22.plala.or.jp/simpleli/text/tech/020220mozilla/020312mozillaZip.html
> インストーラとZIPの違いについて、複数バージョンについて基本的にNG、
> ZIPはインストするディレクトリを変えることによりOKとなっており、
> 少々混乱しております。
> お手数ですが、この点について、ご確認いただけますでしょうか。
> よろしくお願いします。

不明瞭な言い方で混乱させてしまったようですね。すみません。

「安全なもじらの飼い方」で説明していることは、導入において、
インストール版だと、プログラムフォルダーの中身とか、デスクトップや
タスクバーのショートカットのプロパティーなどを置き換えてしまうので、
プログラムの共存自体がしにくい、ということです。
プログラムの導入先ディレクトリーを変え、プログラムフォルダーを変え、
自分でショートカットなどを作り、安全のためにプロファイルも変えれば、
インストーラー版でも複数のZIP版と同様に共存できます。
なお、私はこの方法で、Netscape 7.xの英語版・日本語版・日本語版のブラウザーのみ、の3種をいれてみました。
この場合、それぞれのプログラム・バージョンを交互に使うことは、プロファイルをきちんとわければ問題ありません。

一方、複数バージョンの同時起動ですが、
Mozilla/Netscape 7.xおよびNetscape 4.xの間ではレジストリー等も完全に異なるので、
(メモリーが許せば)同時に起動できます。
しかし、Netscape 7.0英語版とNetscape 7.0日本語版では同時起動できないことを確認できました。
同時に、Mozilla 1.0/1.1/1.2Alphaの間についても、ZIP版では同時起動は不可能であることを確認できました。
でも、Mozillaのインストール版同志では、同時起動ができる可能性を完全に否定できなかったので、あいまいな言い方になってしまいました。
申し訳ありません。

MozillaでもNetscape 7(=Mozilla 1.0.1 RC1)と同様にできないと思いますし、どこかでできない、と読んだような記憶もあるんですが、実はインストーラー版はM17くらいまでしか使っていないので良く知らないのです(^^;
もしかするとインストール版は導入時にレジストリーを分けているかもしれないし、
レジストリーには動くときのデータを保存しないOperaのように、複数バージョンの同時起動ができるかもしれないですしね。

(1) 1.0.1/1.1ともにQuick Launch(高速起動オプション)はオフにしておく
(2) -p "Profile-Name"なしで1.0.1を起動
  => プロファイルマネージャーを経由して立ち上がる
(3) -p "Profile-Name"なしで1.1のショートカットから1.1を起動
  => プロファイルマネージャーを経由せずに立ち上がる
  => about:mozillaで見ると1.0.1になっている
という現象になると思いますので、ご確認ください。

Re[3]: 複数バージョンの起動
(#3002) このトピック中7番目の投稿

> わたくしメは、ウインドウズ2000に、 Wazilla-1.0 と Mozilla-1.1 とを、
> 共にインストーラ版でインストして使っておりますが、残念ながら、
> wada さん同様、同時に使うことは出来ません。
> 複数ヴァージョンを同時使用できればホント便利なんですけどね^^。

やっぱり同時には使えなかったですか。
ブラウザーはブックマークさえコピーすれば、ダメなら戻せばいいし、またOperaとかの他のブラウザー(ただしIEだけは除く)でもいいんですが、
メールはだめな場合には壊れる可能性もあるし、戻しは面倒だし、できれば安定した1.0.1で使えるといいな、と微かな淡い期待を抱いていたんですが、残念(;;)
早いとこブラウザーとメール/ニュースを分離して欲しいですね。

# 10時くらいに返答のページを開いて、放置しておいてついさっき送信したら、
# 堀ゐK さんの返答の前に、私のがはいっちゃったみたいです(^^;
# すみません m(__)m

Re[3]: 複数バージョンの起動
(#3005) このトピック中8番目の投稿

> 「安全なもじらの飼い方」で説明していることは、導入において、
> インストール版だと、プログラムフォルダーの中身とか、デスクトップや
> タスクバーのショートカットのプロパティーなどを置き換えてしまうので、
> プログラムの共存自体がしにくい、ということです。
> プログラムの導入先ディレクトリーを変え、プログラムフォルダーを変え、
> 自分でショートカットなどを作り、安全のためにプロファイルも変えれば、
> インストーラー版でも複数のZIP版と同様に共存できます。

インストーラーによる設定の意味が理解できない方には「基本的にNG」
ということですよね(、蛇足かもしれませんが^^)。


Re[4]: 複数バージョンの起動
(#3006) このトピック中9番目の投稿

みなさん、ご丁寧なレスありがとうございました。
疑問点は全て解決、実際にプロファイルマネージャを経由せずに起動できてます。
複数バージョンの同時起動に関して、私も実験しましたが、最初に起動した
バージョンが立ち上がります。
(1.1を最初に起動後、1.0.1アイコンをクリックしても1.1が起動)


簡単にまとめると、複数バージョンについて、

・インストール --> zip、インストーラ関わりなく可能。
ただし、インストールディレクトリを分け、プロファイルも別にする。

・起動 --> 原則不可能。



Re[5]: 複数バージョンの起動
(#3040) このトピック中10番目の投稿

> 簡単にまとめると、複数バージョンについて、
> ・インストール --> zip、インストーラ関わりなく可能。
> ただし、インストールディレクトリを分け、プロファイルも別にする。

他のスレッドで判明したのですが、複数のバージョンをインストーラーで導入した場合の不都合がありましたので、補足しておきます。

SanのJava 1.4.1を入れた時に、Netscape 7.0とMozillaを一つづづ導入してある場合には、pluginがちゃんと入るのですが、
Netscape 7.0の英語版・日本語版・日本語版のブラウザーのみ、の3種をいれた場合には、pluginを入れてくれませんでした。
Javaのインストーラーはregistry.datを見ているようで、別バージョンの導入前にプログラムディレクトリーを保存しておいてアンインストールをし、システム上は一つだけインストールされた状態にしないと、よろしくないようです。
従って、自分でpluginをコピーする必要があります。

「原則不可」には、このような意味もあったんですね。

なお、解決済み、にしておきます。
済!

[ 次のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -