過去ログ表示


過去ログ 203 を表示

トピック内全 15 記事中の 11 〜 15 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

Re[6]: できました!
(#32132) このトピック中11番目の投稿
(環境: WinXP SP2/Firefox1.5)

2006/06/19(Mon) 05:07:56 編集(投稿者)
2006/06/19(Mon) 05:04:31 編集(投稿者)

> userChrome.js の中身に書き込むことでいろいろ様式の変更ができるのですね。せっかく教えていただいたので、さらにトライしてみます。ただ、DOM Inspector はFirefox 1.5.0.4に対応しておらず、無効化されてしまいました。対応可能になるのを待つことにします。

 あらら、DOM Inspector のバージョンが変っちゃったんですかね。残念です。Release ディレクトリの中のものだから大丈夫だと思ったんですが。

 ということは Firefox を再インストールされたんですか?大変だったでしょう。ご苦労様でした。

 ちなみに userChrome.js は拡張を作るほどじゃないんだけど、Firefox にちょっと手を入れたいというときに便利です。でも XPCOM インターフェースを利用するときは注意してくださいね。バグを出すとシステムに致命的なダメージを出すことがありますから。
済!
Re[7]: できました!
(#32143) このトピック中12番目の投稿
(環境: WinXP SP2/Firefox1.5)

>  あらら、DOM Inspector のバージョンが変っちゃったんですかね。残念です。Release ディレクトリの中のものだから大丈夫だと思ったんですが。

本体についてくる拡張は、そのバージョンの本体にしか対応していません。
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5/win32/xpi/adt.xpi
は 1.5 専用、
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.4/win32/xpi/adt.xpiは 1.5.0.4 専用。

Re[5]: コンテキストメニューのローマ字変更
(#32144) このトピック中13番目の投稿
(環境: WinXP SP2/Firefox1.5)

>>多少危険な作業を伴いますので、現段階の知識では、やらないほうがよろしいかと思います。
>
>  それと最悪差分アップデート、自動アップデート機能が働かなくなると思われます。試してみないとわかりませんが。

変更したファイルが更新の対象となっていなければ、普通にアップデートできます。
変更したファイルが更新の対象となった場合は、差分更新しようとして失敗してフル更新されて、変更した内容が失われます。

ありがとうございます
(#32154) このトピック中14番目の投稿
(環境: WinXP SP2/Firefox1.5)

> 本体についてくる拡張は、そのバージョンの本体にしか対応していません。
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5/win32/xpi/adt.xpi
> は 1.5 専用、
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.5.0.4/win32/xpi/adt.xpiは 1.5.0.4 専用。

ありがとうございます。DOM Inspector、有効になりました。
済!
Re[9]: ありがとうございます
(#32187) このトピック中15番目の投稿
(環境: WinXP SP2/Firefox1.5)

 参考までに。

 DOM Inspector で Firefox の XUL 要素を調べるときは、Firefox の表示を about:blank の状態、つまり何も表示されていない状態にしておいて、DOM Inspector を起動し、File -> Inspect Window -> Mozilla Firefox を選択すればよいです。

 そうすると Firefox の各 XUL 要素を展開したり、検索できます。


[ 前のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -