過去ログ表示


過去ログ 211 を表示

トピック内全 14 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

ダウングレード?
(#33477) このトピック中1番目の投稿
(環境: WinXP SP2/Firefox1.5)

はじめまして。Screen grap を使いたいために、Firefoxを1.5.0.6をインストールしました。ところが、現時点でのScreen grabは、Firefox 1.5.0.6に対応していないようで、アドオンとしてインストールされません。:shock:
Firefox 自体をダウングレード?できるものなのでしょうか? できそうなページを探してみたのですが、見当たりません。 :cry:

Re[1]: ダウングレード?
(#33479) このトピック中2番目の投稿
(環境: WinXP SP2/Firefox3.0a)

http://releases.mozilla.org/pub/mozilla.org/firefox/releases/
に各バージョンがあります。
バージョン名/win32/ja/
に行き、exeをダウンロードしてください。

現在のものをアンインストール、program filesに残ったFirefoxの残骸(pluginsフォルダを除く)を削除、再インストールしてください。

不具合が生じた場合はプロファイルを作り直してください。

Re[2]: ダウングレード?
(#33484) このトピック中3番目の投稿
(環境: WinXP SP2/IE6)

早速のお返事ありがとうございます。1.0.8が、screen grab を使える最新版のようでしたので、インストールしました。インストール後、Firefoxを立ち上げてファイル>>>>ファイルを開く  で、screen grabを選び、firefoxにインストールしました。Firefox を次回起動した時に、screen grabがインストールされるとのことでしたので、一旦Firefoxを終了し、再度起動し、screen grabで保存したい目的のホームページへ行って右クリックでscreen grab で保存しようとするのですが、適当な選択肢がありません。何かがおかしかったのでしょうね。 :(

> http://releases.mozilla.org/pub/mozilla.org/firefox/releases/
> に各バージョンがあります。
> バージョン名/win32/ja/
> に行き、exeをダウンロードしてください。
>
> 現在のものをアンインストール、program filesに残ったFirefoxの残骸(pluginsフォルダを除く)を削除、再インストールしてください。
>
> 不具合が生じた場合はプロファイルを作り直してください。

Re[3]: ダウングレード?
(#33485) このトピック中4番目の投稿
(環境: WinXP SP2/その他)

screen grab0.8はFirefox1.5以降に対応しているようです。
http://andy.5263.org/screengrab/

Re[4]: ダウングレード?
(#33486) このトピック中5番目の投稿
(環境: WinXP SP2/Firefox1.5/Thunderbird1.5)

> screen grab0.8はFirefox1.5以降に対応しているようです。
> http://andy.5263.org/screengrab/

私もこのバージョン入れてみました。
1.0〜1.6対応になっていますが私の環境で他のエクステンションと衝突しているのかも知れませんが動きません。
このScreen grabは変なところがあって(これも私だけの環境なのか)前の0.7がFirefox対応が1.0〜1.5となっているのに(Firefox 1.5.0.6に)インストール出来てしまいそれでかつ動きません。
これの変わりにPearl Crescent Page Saverという拡張が使えます。
http://pearlcrescent.com/products/pagesaver/
機能は似ていますが画像の大きさを指定出来るところはプラスですがブラウザの表示部分内部だけのスクリーンショットしか撮れません。

Re[5]: ダウングレード?
(#33487) このトピック中6番目の投稿
(環境: WinXP SP2/その他)

> このScreen grabは変なところがあって(これも私だけの環境なのか)前の0.7がFirefox対応が1.0〜1.5となっているのに(Firefox 1.5.0.6に)インストール出来てしまいそれでかつ動きません。

1.5までとされていても、拡張機能ファイルの内部仕様(書き方・作り方)によってはインストールすることはできます。
インストールできることと、完全に動作することとは別問題です。

Re[6]: ダウングレード?
(#33488) このトピック中7番目の投稿
(環境: WinXP SP2/Firefox1.5)

> > このScreen grabは変なところがあって(これも私だけの環境なのか)前の0.7がFirefox対応が1.0〜1.5となっているのに(Firefox 1.5.0.6に)インストール出来てしまいそれでかつ動きません。
>
> 1.5までとされていても、拡張機能ファイルの内部仕様(書き方・作り方)によってはインストールすることはできます。
> インストールできることと、完全に動作することとは別問題です。

install.rdfで
<em:maxVersion>1.5</em:maxVersion>
となっているという意味です。
<em:maxVersion>1.5.0.*</em:maxVersion>
でなくても作り方によっては Firefox 1.5.0.6にインストール出来るのですか?

Re[7]: ダウングレード?
(#33489) このトピック中8番目の投稿
(環境: WinXP SP2/その他)

> install.rdfで
> <em:maxVersion>1.5</em:maxVersion>
> となっているという意味です。

minversionも絡んでくる場合もありますが。
1.5となっていてもインストールできてしまう場合があります。

そのほか、NTTなどの拡張機能を経由してもインストールできてしまいます。
また、次期Firefox 2やFirefox 3では拡張機能を経由しなくてもインストールできるようにしてしまうことも可能です。

Re[8]: ダウングレード?
(#33490) このトピック中9番目の投稿
(環境: WinXP SP2/Firefox1.5)

> > install.rdfで
>><em:maxVersion>1.5</em:maxVersion>
>>となっているという意味です。
>
> minversionも絡んでくる場合もありますが。
> 1.5となっていてもインストールできてしまう場合があります。
>
> そのほか、NTTなどの拡張機能を経由してもインストールできてしまいます。
> また、次期Firefox 2やFirefox 3では拡張機能を経由しなくてもインストールできるようにしてしまうことも可能です。

なるほど分かりました。このinstall.rdfのバージョン表示は絶対的ではないのですね。 はじめてしりました。
このエクステンションは以前から入れていてFirefoxのアップデート時にチェックされずそのままになっていましたがある時動かないことを知りアンインストール、もう一度インストールしてもだめ。 それで対応バージョンを調べてみてインストール出来るのは変だと思いながらアンインストール。 その後次のバージョンの対応バージョンが<em:maxVersion>1.6</em:maxVersion>と確認してインストールしかしそれも動かないという経過を辿りまたアンインストールした次第です。

Re[9]: ダウングレード?
(#33492) このトピック中10番目の投稿
(環境: WinXP SP2/Firefox1.5)

> インストールしかしそれも動かないという経過を辿りまたアンインストールした次第です。

公式版には壊れた日本語リソースが入っているため、Firefox 日本語版にインストールすると動作しません。
Firefox 英語版にインストールするか、
日本語版が良いのであれば
http://firefox.geckodev.org/index.php?Screen%20grab%21#a11b266e
にある私製版を使うと良いと思います。


[ 次のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -