過去ログ表示


過去ログ 213 を表示

トピック内全 7 記事中の 1 〜 7 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

日本語メールでブランクが入る
(#33746) このトピック中1番目の投稿
(環境: WinXP SP2/Firefox1.0.7)

2006/09/08(Fri) 13:20:32 編集(投稿者)

Thunderbirdの英語版(1.5.0.5)を使用しています。
メモ帳で作成した日本語を本文として貼り付けて送ることが多いのですが、
作成画面では何もないのに、送信メールには本文中に所々ブランク(スペース)が入ります。
ブランクの規則性も特にわからず、メモ帳の方でも該当箇所にスペースがないか再三確認していますが、
ありません。
日本語版を使えば問題ないのでしょうが、英語版を使う必要があり、ぜひ解決したいです。
パソコン全体の使用言語も英語(US)です。
メモ帳の日本語はUnicodeかUTF-8で保存しています。

Re[1]: 日本語メールでブランクが入る
(#33747) このトピック中2番目の投稿
(環境: WinXP SP2/IE7)

No33746に返信(ぴいさんの記事)
> Thunderbirdの英語版を使用しています。
> メモ帳で作成した日本語を本文として貼り付けて送ることが多いのですが、
> 作成画面では何もないのに、送信メールには本文中に所々ブランク(スペース)が入ります。
> ブランクの規則性も特にわからず、メモ帳の方でも該当箇所にスペースがないか再三確認していますが、
> ありません。
> 日本語版を使えば問題ないのでしょうが、英語版を使う必要があり、ぜひ解決したいです。
> パソコン全体の使用言語も英語(US)です。
> メモ帳の日本語はUnicodeかUTF-8で保存しています。 WinXP SP2/Firefox1.0.7

Re[1]: 日本語メールでブランクが入る(format=flowed?)
(#33748) このトピック中3番目の投稿
(環境: Win2000/SeaMonkey1.5)

> メモ帳で作成した日本語を本文として貼り付けて送ることが多いのですが、
> 作成画面では何もないのに、送信メールには本文中に所々ブランク(スペース)が入ります。

> メモ帳の日本語はUnicodeかUTF-8で保存しています。

メール作成時の文字コードには何を設定していますか?
ドラフトで保存してメールのソースを表示し、Content-Type: text/plain; charset=xxx; format=flowed; ... のようなヘッダーを確認してみてください。

Unicode(UTF-8)でformat=flowedになっているんじゃないかな?
作成時のformat=flowedのdelsp=yesがまだサポートされていないので、今のところiso-2022-jpとかだとformat=flowedは使わないようになっているのですが、Unicode(UTF-8)だとformat=flowedで送られるようです。
(A)作成時の文字コードをiso-2022-jpに設定して、ドラフト保存&ソース表示、
(B)mailnews.send_plaintext_flowed=falseを設定して、ドラフト保存&ソース表示、
http://www.mozilla.org/unix/customizing.html
だとどうなりますか?

Re[2]: 日本語メールでブランクが入る(format=flowed?)
(#33753) このトピック中4番目の投稿
(環境: WinXP SP2/Firefox1.0.7)

> Unicode(UTF-8)でformat=flowedになっているんじゃないかな?
まさにそうでした。ありがとうございます。

> (B)mailnews.send_plaintext_flowed=falseを設定して、ドラフト保存&ソース表示、
これがわからなくて試せなかったんですけど
> http://www.mozilla.org/unix/customizing.html
でやり方を探せば載ってるっていうことでしょうか?

ちょっと気になったのでやってみたくて。

Re[2]: 日本語メールでブランクが入る
(#33754) このトピック中5番目の投稿
(環境: WinXP SP2/IE7)

No33747に返信(柏崎さんの記事)
コメント無しで投稿されてしまいました。お詫びします。
#名前がない、メルアド不正等の度重なる注意メッセージに応じていたら、
#いつの間にか、投稿用編集内容が全部引用文になってしまったようです…

Re[3]: 日本語メールでブランクが入る(format=flowed?)
(#33768) このトピック中6番目の投稿
(環境: Win2000/Firefox3.0a)

ああ、まさにGeckoのバグというか仕様の不備というか、そういうものです、これ。 WADAさんの指摘通り、format=flowedが原因です。
# Fx2でURLの折り返しが修正されなかった原因のひとつです。

そうか、UTF-8でもformat=flowedが付いてしまうんですね……
bugzilla-jpでバグをたてて、ちょっと対応策を検討してみます。

ぴいさんの対応としては、WADAさんの上げている(B)をお勧めします。
[Tools] -> [Options] -> Advanced -> General -> Config Editor
から設定を変更できます。

Re[4]: 日本語メールでブランクが入る(format=flowed?)
(#33769) このトピック中7番目の投稿
(環境: Win2000/Firefox3.0a)

No33768に返信(中野雅之さんの記事)
> bugzilla-jpでバグをたてて、ちょっと対応策を検討してみます。

既に
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2976
がありましたね。


このトピックの全ページ / [0]

返信不可


- Child Tree -