過去ログ表示


過去ログ 217 を表示

トピック内全 10 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

(環境: WinXP SP2/Firefox1.0.7)

Firefox1.0.7/UserAgentSwitcher0.6.9JPを使っています

ホームページをgooにしていますが、最近gooがリニューアルしました。
画面の右側に「表示内容の変更」ボタンにより、「スポーツ」「天気」「テレビ番組」など表示項目の設定ができる様になりましたが(UserAgentSwitcher「標準」時)、
UserAgentSwitcher設定を「InternetExplorer6」にしてgooトップを開くと「表示内容の変更」ボタンが効きません(何も起きない)。

※JavaScriptコンソールにはエラーが表示されています
エラー: uncaught exception: [Exception... "Illegal operation on WrappedNative prototype object" nsresult: "0x8057000c (NS_ERROR_XPC_BAD_OP_ON_WN_PROTO)" location: "JS frame :: http://x.goo.ne.jp/banner3/0common/flash_fix00.js :: dclkWrite :: line 5" data: no]
----------------------------------------------------------------
エラー: Effect is not defined
ソースファイル: http://www.goo.ne.jp/js/1.js
行: 1
----------------------------------------------------------------
尚、gooに問い合わせしましたら「UserAgentへの対応は難しい」との事でした。


UserAgentSwitcher設定を「InternetExplorer6」で機能させることは可能でしょうか?

(環境: WinXP SP2/SeaMonkey1.0)

IE Tabを使用してみたらいかがですか?
https://addons.mozilla.org/firefox/1419/

#SeaMonkey を使用していて、拡張はIE Tabのみです。
IE Tabを使用しなくても、普通に goo の設定ができました。

(環境: Linux/Firefox1.5)

> UserAgentSwitcher設定を「InternetExplorer6」で機能させることは可能でしょうか?
不可能だと思います。
UserAgentSwitcherは動物に着ぐるみを着せるようなものです。
狼でも食べられるのに、狼だからという理由だけで餌を出してくれない時には有効です。
兎の皮を被った狼は、あくまでも狼なので兎専用の餌は食べられません。


#「標準」ではなく「InternetExplorer6」で機能させたい理由がわかりません。
#どうしても「InternetExplorer6」で機能させたいならIE6を使えばいいだけなのに。

(環境: WinXP SP2/Firefox1.5)

> Firefox1.0.7/UserAgentSwitcher0.6.9JPを使っています
1.0.x 系統はサポートが終了しています。10個以上のセキュリティホールが放置された状態になりますので、今すぐ最新版へとアップデートすることをお勧めします。

> 尚、gooに問い合わせしましたら「UserAgentへの対応は難しい」との事でした。
>
>
> UserAgentSwitcher設定を「InternetExplorer6」で機能させることは可能でしょうか?
ブラウザの UserAgent 設定は自分がどのブラウザを使用しているか自己申告するためのものです。
今回の場合はこの UA 情報を解析してブラウザを判別し、IE は IE 用の、Fx は Fx 用のスクリプトを出力しているのだと思います。
UA 偽装で IE 用のスクリプトが出力されてしまうのは一般的なことであり、ある程度はやむをえない部分もあるでしょう。
UA 情報もブラウザ判別のためには重要な情報のひとつです。

(環境: WinXP SP2/IE6)

ご回答ありがとうございます

> 10個以上のセキュリティホールが放置された状態
わぁ〜お。
分かりました。

> 今回の場合はこの UA 情報を解析してブラウザを判別し、
分かりました。

(環境: WinXP SP2/IE6)

ご回答ありがとうございます

> 不可能だと思います。
分かりました

> #「InternetExplorer6」で機能させたい理由
特にありませんが、
以前、「IEしかサポートしないHPがある」と聞いたので、
いつもUserAgentで「IE6」に偽装して使っていました。

> #どうしても「InternetExplorer6」で機能させたいならIE6を使えばいいだけなのに。
そうですかぁ〜

(環境: WinXP SP2/IE6)

ご回答ありがとうございます

> IE Tabを使用してみたらいかがですか?
そういう手がありましたか…
一応、IE Tab1.0.9.5を使っていますが、UserAgentを「IE6」にすると
微妙な動き(出来たり出来なかったり)をします


> #SeaMonkey を使用していて、拡張はIE Tabのみです。
> IE Tabを使用しなくても、普通に goo の設定ができました。
バージョンによる違いと思われますね


★3人の方にご回答頂き…
UserAgentを「IE6」で使う必要が無いような気がしてきました。
現在、ほとんどFirefox使用で、時々IE6を使っていますが、
UserAgent(偽装)を使ってまで、Firefoxで見たいという訳でもありません。
それにFirefox起動時は、UserAgentは「標準」なのでgooは正常に機能しますし。。。

※「IE Tab」は気付きませんでしたが…(^_^;)


納得いたしましたので、「解決」とさせて頂きます。
皆さんありがとうございました。
済!
(環境: WinXP SP2/SeaMonkey1.0)

IE Tabはバージョンがあがっています。最新バージョン(IE Tab 1.1.1.4)を入れてください。
古いバージョンはセキュリティー的に問題があったような気がする。

(環境: WinXP SP2/Firefox1.5)

> 以前、「IEしかサポートしないHPがある」と聞いたので、
> いつもUserAgentで「IE6」に偽装して使っていました。
IEしかサポートしないと言うものは大きく分けて2種類あります。

ひとつは IE 以外に関して動作確認が出来ていない、IE が多数派だからそれ以外を無視する、他のブラウザで動作確認をするのがわずらわしい、などの理由で IE のみをサポート対象としているものです。

もうひとつは IE の独自拡張等を使っており非 IE では正常に利用できないため、IE 以外に代替的機能を提供できないため IE のみをサポートすると言うもの。

前者の場合は UA を弾かれたとしても UA 偽装で正常な利用が出来ますが、後者の場合は UA を偽装しても無意味です。

(環境: WinXP SP2/IE6)

2006/10/12(Thu) 00:54:12 編集(投稿者)

>Toshiさん
>不知名百舌鳥等さん

度々スミマセン

>>>Toshiさん

> IE Tabはバージョンがあがっています。最新バージョン(IE Tab 1.1.1.4)を入れてください。
Firefox1.0.7で「IE Tab 1.1.1.4」は使えなかったと思いますが。。。
しかし…
本日「Firefox1.5.0.7」をインストール、「IE Tab 1.1.1.4」にして見たら、
UserAgent「Internet Explorer 6(Windows XP)」で
gooホームページのボタンが機能するようになりました。
※「IE Tab」を使わずFirefox1.5エンジンで表示させると、やはり機能しませんが…

ありがとうございました。



>>>不知名百舌鳥等さん

分かりやすい解説をありがとうございます
済!

このトピックの全ページ / [0]

返信不可


- Child Tree -