過去ログ表示


過去ログ 250 を表示

トピック内全 19 記事中の 1 〜 10 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

送信日時がありもしない時間に狂います。
(#39413) このトピック中1番目の投稿
(環境: Win2000/Other/Thunderbird1.5)

サンダーバードで「送信日時」がありもしない時間で表示されます。
たとえば、17日15:00に送信したのに、
送信済みボックスを見ると「17日22時」に送信したことになっています。
↑これって未来です…。他の受信したメールも、とてつもない送信時間になっています。

ちなみにPCのタイムゾーン設定は何度も確認しましたがあっていますし、
コマンドプロンプト画面でもTZ=JST-9となっています。
どうしてでしょうか・・・・・('_`)。

テストとして、自分で自分にメールしたところ…。
たとえば16時に自分から自分へテストで送信したのに…。

 送信済みメールのヘッダーを見ると…
 「From - Sat Aug 18 00:48:48 2007
   X-Mozilla-Status: 0001
   X-Mozilla-Status2: 00800000
   Date: Sat, 18 Aug 2007 00:48:46 +0900
   User-Agent: Thunderbird 1.5.0.12 (Windows/20070509)
   MIME-Version: 1.0
   Content-Type: text/plain; charset=ISO-2022-JP
   Content-Transfer-Encoding: 7bit

 受信した方のメールを見ると
 「From - Sat Aug 18 00:48:51 2007
  X-Account-Key: account2
  X-Mozilla-Status: 0001
  X-Mozilla-Status2: 00000000
  Received: (qmail 49162 invoked from network); 17 Aug 2007 15:51:51 +0900
 SMTP; 17 Aug 2007 15:51:51 +0900
Date: Sat, 18 Aug 2007 00:48:46 +0900
User-Agent: Thunderbird 1.5.0.12 (Windows/20070509)
MIME-Version: 1.0
Status: U
Content-Type: text/plain; charset=ISO-2022-JP
Content-Transfer-Encoding: 7bit」

 ・・・・・・・となっていました。
 《Date: Sat, 18 Aug 2007 00:48:46 +0900》…って
 かなりおかしいですよね。
 どうしてでしょうか。
 
 お願いします、どなたか助けてください。

Re[1]: 送信日時がありもしない時間に狂います。
(#39415) このトピック中2番目の投稿
(環境: WinXP SP2/Firefox2.0/Thunderbird2.0)

> コマンドプロンプト画面でもTZ=JST-9となっています。

ということであれば、
http://forum.mozilla.gr.jp/?mode=al2&namber=11313&rev=&&KLOG=75
と同様のケースで、環境変数の問題ではありませんか?

Re[2]: コマンドプロンプトで削除しました
(#39417) このトピック中3番目の投稿
(環境: Win2000/Other/Thunderbird1.5)

2007/08/19(Sun) 11:59:02 編集(投稿者)
2007/08/19(Sun) 11:58:35 編集(投稿者)
2007/08/19(Sun) 11:58:25 編集(投稿者)

> > コマンドプロンプト画面でもTZ=JST-9となっています。
>
> ということであれば、
> http://forum.mozilla.gr.jp/?mode=al2&namber=11313&rev=&&KLOG=75
> と同様のケースで、環境変数の問題ではありませんか?

 ↑一応、この質問を拝読していたんですが//・。
 「TZ=JST-9」というのが悪さをしていたのでしょうか?
 今削除してみましたら、日時がもどりました!!!
 しばらく様子を見ようと思います。
 本当にありがとうございました!

Re[3]: コマンドプロンプトで削除しました
(#39419) このトピック中4番目の投稿
(環境: WinXP SP2/SeaMonkey1.1)

2007/08/19(Sun) 13:45:23 編集(投稿者)

>  「TZ=JST-9」というのが悪さをしていたのでしょうか?

そうみたいですね。
http://www.m17n.org/mlarchive/mule-ja/200102/msg00072.html
環境変数をセットしたら文字列のタイムゾーン名を返すのが仕様のようですから、それをちゃんとサポートしないThunderbirdが悪い、ということになっちゃうのかな?
(追記)
でも、JST-9(=GMT)だと言っているんだから、日本の時刻とはちょうど9時間ずれて当然。
PST+3とかやってずれ方を見ると、Thunderbirdがここをちゃんと見ているのか、+0900とかでないとダメなのかわかるかも。
(追記おしまい)
済!
Re[4]: コマンドプロンプトで削除しました
(#39438) このトピック中5番目の投稿
(環境: Win2000/Other/Thunderbird1.5)

「済み」にしたのに、まだ時間がおかしいです。

> >  「TZ=JST-9」というのが悪さをしていたのでしょうか?

↑これを削除したとたん、こんどは、やっぱり時間が9時間ずれます。
・・・・・・・・・・・????(´ヘ`;)

> > http://www.m17n.org/mlarchive/mule-ja/200102/msg00072.html
> 環境変数をセットしたら文字列のタイムゾーン名を返すのが仕様のようですから、それをちゃんとサポートしないThunderbirdが悪い、ということになっちゃうのかな?


↑すいません、拝読したのですが(リンク先も)、
どうすればいいのか??? よくわからなかったのですが。
wadaさま、どうかご教授ください<(_ _)>

Re[5]: コマンドプロンプトで削除しました
(#39439) このトピック中6番目の投稿
(環境: WinXP SP2/Firefox2.0)

> 「済み」にしたのに、まだ時間がおかしいです。

コマンドプロンプトで削除しましたって言うのが気になってはいたのですが、
コマンドプロンプトで unset してもそのシェル内で環境変数が消えるだけです。
Autoexec.bat とか、システムのプロパティから環境変数を削除するか、
バッチを書いて unset してから起動するようにしないと駄目じゃないんですか?

え?…えっとぉ。(;´▽`A``
(#39442) このトピック中7番目の投稿
(環境: Win2000/IE6/Thunderbird1.5)

> コマンドプロンプトで削除しましたって言うのが気になってはいたのですが、
> コマンドプロンプトで unset してもそのシェル内で環境変数が消えるだけです。
> Autoexec.bat とか、システムのプロパティから環境変数を削除するか、
> バッチを書いて unset してから起動するようにしないと駄目じゃないんですか?

windows2000なんで、「コントロールパネルのシステムのプロパティ」から
環境変数を変更してみたんですが…ダメだったんでしょうか?
TZ=JST-9を消しても、残しても、時間がずれるなんて…。
たかがメールの時間…かもしれませんが、
例えば「明日の件ですが」とか書かれてしまうと、とても困ってしまいます。
ど素人なので、これ以上判らず、途方にくれています。
助けてくださいませ<(_ _)>

Re[7]: え?…えっとぉ。(;´▽`A``
(#39445) このトピック中8番目の投稿
(環境: WinXP SP2/Firefox2.0)

> windows2000なんで、「コントロールパネルのシステムのプロパティ」から
> 環境変数を変更してみたんですが…ダメだったんでしょうか?

コマンドプロンプトで削除したというから、てっきり unset しただけだと
思ったので。そちらでやったことはシステムのプロパティから環境変数を削除して、
コマンドプロンプトで環境変数が消えていることを確認されたということですね。
環境変数を変えた後、念のため OS を再起動して、確認してみましたか?
# 即時反映のはずだからプロセス再起動だけでもいいはずなんですけど、念のためね。

Re[8]: こんな症状です。
(#39450) このトピック中9番目の投稿
(環境: Win2000/Other/Thunderbird2.0)

>そちらでやったことはシステムのプロパティから環境変数を削除して、
> コマンドプロンプトで環境変数が消えていることを確認されたということですね。
> 環境変数を変えた後、念のため OS を再起動して、確認してみましたか?
> # 即時反映のはずだからプロセス再起動だけでもいいはずなんですけど、

↑はい。なにかシステムを変更した後は、必ず再起動するようにしています。
けれど…ずれるんです(´ヘ`;)

↓例えばですが…表示が変なメールのソース(一部)です。
==============================
送信日時:2:10
From - Mon Aug 20 14:24:29 2007
X-Account-Key: account2
X-UIDL:************************
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:
Return-Path: ***********
Delivered-To:************
Received: (qmail***** invoked from network); 20 Aug 2007 11:13:56 +0900
Received: from ************* by
     mail.********* SMTP; 20 Aug 2007 11:13:56 +0900
Errors-To: *************
Date: Mon, 20 Aug 2007 11:13:50 +0900 (JST)
==============================
これでなにか判りますでしょうか?

Re[9]: こんな症状です。
(#39454) このトピック中10番目の投稿
(環境: WinXP SP2/Firefox2.0/Thunderbird2.0)

もしや驚速シリーズの何かを使ってませんか?


[ 次のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -