過去ログ表示


過去ログ 273 を表示

トピック内全 3 記事中の 1 〜 3 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

(環境: WinXP SP2/Other)

OBJECT要素に対してborderプロパティを指定したのですが、プラグインを使用するものが表示されません。

上記のような問題があるのかどうか判断するため、以下のようなソースを使用しました。
<!-- ここから -->
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html lang="en">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Shift_JIS">
<meta http-equiv="Content-Style-Type" content="text/css">
<title>test</title>
<style type="text/css"><!--
html{ background:#333; text-align:center; }
object{ margin:auto; border:2px #22F solid; padding:4px; }
--></style>
</head>
<body>
<object data="test.swf" width="240" height="240" type="application/x-shockwave-flash">
<param name="movie" value="test.swf">
<param name="loop" value="true">
<param name="quality" value="high">
</object>
<object data="test.png" width="150" height="150" type="image/png"></object>
<object data="test.wmv" width="240" height="240" type="video/x-ms-wmv"></object>
</body>
</html>
<!-- ここまで -->

*結果
Firefox3ではpngを表示するOBJECT要素のみ、padding、borderが表示されました。
IE7では全てのOBJECT要素でborderのみが表示され、Opera 9.50では、padding、border共に表示されました。
一応拡張機能の影響でないことを確かめるため、一度、全ての拡張機能を無効化して再起動してみたのですが結果は変わりませんでした。

この問題はFirefoxのバグなのだと思うのですが、どうなのでしょうか。
もし、バグなのだとすればどうすればよいのでしょうか。

(環境: WinXP SP2/Firefox2.0)

たぶんこれだと思います。
https://bugzilla.mozilla.org/show_bug.cgi?id=236089

(環境: WinXP SP2/Other)

すみません、それのようです。
Bugzillaのほうで検索を掛けるのを忘れていました。
済!

このトピックの全ページ / [0]

返信不可


- Child Tree -