過去ログ表示


過去ログ 278 を表示

トピック内全 8 記事中の 1 〜 8 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

Firefox 3.0.1向けのJLPを探しています
(#43398) このトピック中1番目の投稿
(環境: WinXP SP3/Firefox3.0)

こんにちは。
先ほどOS/2版のFirefoxを3.0→3.0.1にアップデートしたところ、JLP(firefox-3.0.ja.langpack-2.0.23.xpi)が非対応ということで無効化されました。

Mozilla/5.0 (OS/2; U; Warp 4.5; ja; rv:1.9.0.1) Gecko/2008071518 Firefox/3.0.1

Windowsでも確認しました。

Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1

(注:general.useragent.localeを変更しているのでjaになっていますが、表示はどちらも英語のままです)

泉州もじらでしたら3.0.1向けのJLPがあるようなのですが、標準語版のJLPはどこかにありませんでしょうか。
http://www.freedom.ne.jp/mukkst/index/MOZCAPE/MAIDO-MOZ

それにしてもFirefox 3ではセキュリティアップデートごとにJLPも更新する必要があるとすれば、面倒な場合もありそう(ダイヤルアップ環境とかオフラインとか)なので、サクッと裏技でバージョンチェックを回避する方法はないでしょうかね。 Confused

Re[1]: Firefox 3.0.1向けのJLPを探しています
(#43399) このトピック中2番目の投稿
(環境: WinXP SP3/Minefield)

プロファイルフォルダ内の言語パックのinstall.rdfファイル内に記述されているmaxversionを3.0.*にしておけば以後3.0.*系列には対応します。
(Firefoxを終了してから修正してください。)

Windows版なら素直に日本語版を入れておけばいいと思いますが。

Re[1]: Firefox 3.0.1向けのJLPを探しています
(#43400) このトピック中3番目の投稿
(環境: WinVista/Firefox3.0)

ここに各国語版のJLPがあります。
私はFreeBSDで使いましたが問題ないようです。
OS/2でもいけるのではないでしょうか?

ftp://ftp.mozilla.org/pub/firefox/releases/3.0.1/win32/xpi/

Re[2]: Firefox 3.0.1向けのJLPを探しています
(#43401) このトピック中4番目の投稿
(環境: WinXP SP3/Firefox3.0)

> 私はFreeBSDで使いましたが問題ないようです。
> OS/2でもいけるのではないでしょうか?
>
> ftp://ftp.mozilla.org/pub/firefox/releases/3.0.1/win32/xpi/

おお!ありがとうございます。OS/2版が標準語表示にできました。 Mr.Green

そっかftpサイトの方は未チェックでした。これからはこちらにリンクを張っておこう。

ちなみに ja.xpiのinstall.rdf を見てみましたが、maxVersionは3.0.1になっていますね。
http://developer.mozilla.org/ja/docs/install.rdf
済!
Re[3]: Firefox 3.0.1向けのJLPを探しています
(#43402) このトピック中5番目の投稿
(環境: WinXP SP3/Minefield)

> ちなみに ja.xpiのinstall.rdf を見てみましたが、maxVersionは3.0.1になっていますね。
> http://developer.mozilla.org/ja/docs/install.rdf

web上のものなど関係ありません。
それに、3.0.1用のものが出ているみたいですので、あなたが示したものも修正されていることでしょう。

もう3.0.1用のものを入れてしまったと思いますが、それを入れる前のあなたのプロファイルフォルダ内にあるinstall.refのmaxversionの記述がポイントなのです。

Re[4]: Firefox 3.0.1向けのJLPを探しています
(#43403) このトピック中6番目の投稿
(環境: WinXP SP3/Firefox3.0)

No43402に返信(palさんの記事)
> それに、3.0.1用のものが出ているみたいですので、あなたが示したものも修正されていることでしょう。
>
> もう3.0.1用のものを入れてしまったと思いますが、それを入れる前のあなたのプロファイルフォルダ内にあるinstall.refのmaxversionの記述がポイントなのです。

3.0.1専用のja.xpiを入れても、「それを入れる前の」 firefox-3.0.ja.langpack-2.0.23.xpiのmaxversionが修正されるわけではありません。

Re[5]: Firefox 3.0.1向けのJLPを探しています
(#43405) このトピック中7番目の投稿
(環境: WinXP SP3/Minefield)

類似のアドオン(今回の場合は同一言語の言語パック)を並列で入れたのですか?
類似のものを入れていると不具合の原因となります。
(以前のものを削除して入れたのなら問題ないですが。)

**
通常同じものを入れれば、以前のものは修正(上書き)されます。

Re[1]: Firefox 3.0.1向けのJLPを探しています
(#43447) このトピック中8番目の投稿
(環境: Mac/Firefox3.0)

> JLP(firefox-3.0.ja.langpack-2.0.23.xpi)

それはあくまで開発版です。
注意事項としては、バージョンは違いますが
http://forums.firehacks.org/l10n/viewtopic.php?t=729
を見てください。
「共に L10N を行ってくださる貢献者や QA (品質保証)テストを行ってくださる協力者向けのものです。決して一般のユーザに広く使用を推奨できるものではありません。 」
「単に英語版の公式リリースや英語のみの独自ビルド等に日本語を追加する方法として紹介するのであれば、mozilla.org により公式リリースとして公開されている XPI パッケージがあります。 」


このトピックの全ページ / [0]

返信不可


- Child Tree -