過去ログ表示


過去ログ 295 を表示

トピック内全 5 記事中の 1 〜 5 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0]

ブラウザ判定のミス?
(#45820) このトピック中1番目の投稿
(環境: Linux/Other)

トップページにあるブラウザ判定ですが、Iceweasel 3.0.5(Firefox 3.0.5相当)が古いと判定されています。UAは以下。
Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.0.5) Gecko/2008122011 Iceweasel/3.0.5 (Debian-3.0.5-1)

Re[1]: ブラウザ判定のミス?
(#45823) このトピック中2番目の投稿
(環境: WinXP SP3/Firefox3.0)

> トップページにあるブラウザ判定ですが、Iceweasel 3.0.5(Firefox 3.0.5相当)が古いと判定されています。UAは以下。
> Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.0.5) Gecko/2008122011 Iceweasel/3.0.5 (Debian-3.0.5-1)

外部の者の邪推ですが,UserAgentを見て判断しているだけだと思われ,
“Iceweasel/3.0.5”となっているために誤認していると推察されます。
気になるようでしたら,
“Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.0.5) Gecko/2008121523 Firefox/3.0.5 (.NET CLR 3.5.30729) (tete009 SSE PGO)”
と,Minefield/3.0.5の部分をFirefoxと変えてしまっていますが,about:configで変更すればよいかと思います。
P.S.私の場合,Minefield/3.0.5となっているとGoogleツールバーがインストールできないという問題が以前あり,その対応として変更しています
Embarassed

Re[2]: ブラウザ判定のミス?
(#45825) このトピック中3番目の投稿
(環境: WinVista/Firefox3.0)

> > トップページにあるブラウザ判定ですが、Iceweasel 3.0.5(Firefox 3.0.5相当)が古いと判定されています。UAは以下。
>>Mozilla/5.0 (X11; U; Linux i686; ja; rv:1.9.0.5) Gecko/2008122011 Iceweasel/3.0.5 (Debian-3.0.5-1)
>
> 外部の者の邪推ですが,UserAgentを見て判断しているだけだと思われ,
> “Iceweasel/3.0.5”となっているために誤認していると推察されます。
> 気になるようでしたら,
> “Mozilla/5.0 (Windows; U; Windows NT 5.1; ja; rv:1.9.0.5) Gecko/2008121523 Firefox/3.0.5 (.NET CLR 3.5.30729) (tete009 SSE PGO)”
> と,Minefield/3.0.5の部分をFirefoxと変えてしまっていますが,about:configで変更すればよいかと思います。
> P.S.私の場合,Minefield/3.0.5となっているとGoogleツールバーがインストールできないという問題が以前あり,その対応として変更しています
> :oops:
修正しました。(が、Iceweaselは独自パッチが当たっていたりするので、Mozilla扱いすべきか考え中です。今後、同様の判定方法に戻る可能性があります。)

Re[3]: ブラウザ判定のミス?
(#45832) このトピック中4番目の投稿
(環境: Linux/Other)

> 修正しました。(が、Iceweaselは独自パッチが当たっていたりするので、Mozilla扱いすべきか考え中です。今後、同様の判定方法に戻る可能性があります。)

Iceweaselでは「Firefoxを使ってね」的なメッセージを出されるのならわかりますけど、今までのように古くないにも係らず「古い」的なメッセージを出されるのはいただけません。
Mozilla扱いしないのであれば、ちゃんとMozilla以外の扱いにしてください。

Re[4]: ブラウザ判定のミス?(Re[3] fixed)
(#45834) このトピック中5番目の投稿
(環境: WinVista/Firefox3.0)

> > 修正しました。(が、Iceweaselは独自パッチが当たっていたりするので、Mozilla扱いすべきか考え中です。今後、同様の判定方法に戻る可能性があります。)
>
> Iceweaselでは「Firefoxを使ってね」的なメッセージを出されるのならわかりますけど、今までのように古くないにも係らず「古い」的なメッセージを出されるのはいただけません。
> Mozilla扱いしないのであれば、ちゃんとMozilla以外の扱いにしてください。
要望を反映しました。IE/Safariなどと同等のメッセージを出すように修正しました。


このトピックの全ページ / [0]

返信不可


- Child Tree -