過去ログ表示


過去ログ 38 を表示

トピック内全 17 記事中の 11 〜 17 番目を表示
[ 最新記事及び返信フォームをトピックトップへ ]
このトピックの全ページ / [0] [1]

Re[5]: Re: 便乗質問
(#5461) このトピック中11番目の投稿

> 1.4.2ベータ、って、Sun Javaの1.4.2ベータ版のことです。
> 4月の初めくらいに公開されたんだったかな。
私の環境で試してみたところ、1.4.2Bでも動きました。

>>それから、私はmozillaにしてからjava plug-inを自動でブラウザに導入できた
> 試しがありません。
>>インストール先がデフォルトでは無いせいでしょうか。
> Sun Javaのインストーラーは、1.4.1からだったと思いますが、Mozillaも認識して
>くれるようになったはずです。
1.4.2では、mozilla1.1以降という項目がでてきました。
1.4.1_02ではインストール時にはIE以外、項目そのものがありませんでした。
1.4.2Bで初めて自動でインストールができました。感動です。

> なお、Sun Java 1.4.2(1.4.1_02じゃなく)からは、NPJava14.dll というのもできるようです。
> 手動でコピーすると、忘れそうですね(^^;
本当だ!とするとこれまでは1.4の機能をつかったアプレットは
動かなかったということなのだろうか…
手動コピーの際はbinフォルダのNP*****.dllをすべて移動することにしているので
取りこぼしの心配はありません。
java plug-inがでてから基本的には手動で移すことが多かったので
その辺は抜かりはないはず……!?
jdkをインストールするとwindowsの方(今はprogram files、昔はwindowsに
インストールされていた)とjdkのフォルダと2つにjreが書き込まれるので
片方のjreを消すことを思い立ち、いろいろ試行錯誤した結果です。
それぞれのjreが微妙に違うので、消したい方を「切り取り」してもう一方に
上書き保存。後はレジストリをいじると大丈夫です。

1.4あたりからjreだけで40Mくらいあるので、2つもあると結構大変です。
試してみてはいかがでしょうか?
もちろん、バックアップと自己責任の覚悟が必要ですが。

以上、
win98再インストールついでに「田中式win98安定化」を試して
失敗したmatsuより


Re[6]: Re: 便乗質問
(#5464) このトピック中12番目の投稿

うまくいかないですね。
javaプラグインもすべて有効になっており、
NPOJI610.dll
もフォルダーに存在するのですが。。。。

Re[7]: Re: 便乗質問
(#5465) このトピック中13番目の投稿

> うまくいかないですね。
> javaプラグインもすべて有効になっており、
> NPOJI610.dll
> もフォルダーに存在するのですが。。。。


間違えて送信しました。Re[8]: Re: 便乗質問
(#5467) このトピック中14番目の投稿

謝ってリターンキーを押してしまい、そのまま投稿されてしまいました。
>>うまくいかないですね。
>>javaプラグインもすべて有効になっており、
>>NPOJI610.dll
>>もフォルダーに存在するのですが。。。。
>
複数のjreがあると動かないかもしれません。
それから、コントロールパネルのjava plug-in設定は起動しますか?
起動するなら、そこでjreを選んでみて試してみてください。
起動しないようなら、java plug-inが入っていても、javaそのものが
動かない状況になっていると考えられます。
動かないといっても、java plug-inからということですが。
netscapeやmozillaのplug-in欄にjava plug-inが表示されていても
それは有効になっているということではありません。
それはdllが入っていてそのことが認識されているということにすぎないのです。
java plug-inからjava実行のメッセージがきてもjreが動かない状況では
アプレットは動作しません。

もしかすると、レジストリの設定がうまくいっていないのかもしれません。
したの文字列をコピーしてメモ帳に張り付けて、手直しし、java.regなどとして
保存し、レジストリに書き込むこともできます。
ただ、ここの文に予期しないスペースなどが入らないとも限らないので、
どなたかが、レジストリファイルを作ってくれるといいのですが……
REGEDIT4

[HKEY_LOCAL_MACHINE\Software\JavaSoft]

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Plug-in]

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Plug-in\1.4.1_02]
"JavaHome"="D:\\j2sdk1.4.1_02\\jre"
"UseJava2IExplorer"=dword:00000001
"HideSystemTrayIcon"=dword:00000000

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Runtime Environment]
"CurrentVersion"="1.4"

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Runtime Environment\1.4]
"JavaHome"="D:\\j2sdk1.4.1_02\\jre"
"MicroVersion"="1"
"RuntimeLib"="D:\\j2sdk1.4.1_02\\jre\\bin\\client\\jvm.dll"

[HKEY_LOCAL_MACHINE\Software\JavaSoft\Java Runtime Environment\1.4.1_02]
"JavaHome"="D:\\j2sdk1.4.1_02\\jre"
"MicroVersion"="1"
"RuntimeLib"="D:\\j2sdk1.4.1_02\\jre\\bin\\client\\jvm.dll"

上の"JavaHome"と"RuntimeLib"の場所を自分のjreがある場所に書き換えると
うまくいくと思います。
私の場合は、前に書いたとおり、jdkにあるjreをjava plug-inとして
使っているので、c:\program files\javasoft\j2jre?.?にはなっていません。
これを見て書き換える前に、いちどレジストリをのぞいてみてはどうでしょうか?
もし心配であれば、レジストリでHKEY_LOCAL_MACHINE\Software\JavaSoft以下を
書き出しておけば後で書き換えられますし、scanregwでバックアップをとっておき
DOSで起動させて、scanreg /restoreでも戻せます。
わかっている方には余計なことですが、念のため。

とにかく、コントロールパネルのjava plug-in設定が立ち上がるかどうかが
最初に調べることです。

Re[6]: Re: 便乗質問
(#5470) このトピック中15番目の投稿

matsuさん、こんにちは。
丁寧に教えてくださり、ありがとうございます。

私は、Netscape7.0.1をインストールした後にMozilla1.3zip判を解凍して使っています。その後NetscapeでJavaを使えるようにしたら、自然とMozillaでも、動いてしまいました。C:\Documents and Settings\"User"\Application Data\Mozillaのpluginreg.datで、Netscape下のプラグインを両方で使えるようにしているのかなあ、と思っていたところです。

>>また稚拙ながら自分で作ったjavascriptも動いているようです。
> javascriptはjavaではありません。
違うものだとは本に書いてあったのですが、javascriptもjreで動くのかと思っていました。お恥ずかしい限りです。

少しでも何かの足しになればと思い、書き込ませていただきました。今後とも、よろしくお願いいたします。

Re[6]: Re: 便乗質問(1.4.2ベータはMozillaでもOK)
(#5472) このトピック中16番目の投稿

>> Sun Javaのインストーラーは、1.4.1からだったと思いますが、Mozillaも認識して
>> くれるようになったはずです。
> 1.4.2では、mozilla1.1以降という項目がでてきました。
> 1.4.1_02ではインストール時にはIE以外、項目そのものがありませんでした。

1.4.1のインストーラーからMozillaもサポートされた、というのはガセネタでしたね(^^;
私のところはプラグイン導入用にNetscape7を入れていたので、それでNetscape 6の項目がでてきていたようです。
ウソついて、申し訳ないです m(__)m

> 1.4.2では、mozilla1.1以降という項目がでてきました。

そういうことですか。
Javaプラグインの制御が、Netscape(Mozilla 1.0)とMozillaで分けられたんですね。
私が入れた時は、MozillaはZIP版しかなくて、Netscape 7だけの状態でした。
Java 1.4.1_02まではNetscape7からプラグインをコピーするだけでよかったので、1.4.2でも、と思っていたのが敗因(^^;
で、生まれてから初めてインストーラー版Mozillaでインストールし、それからJDKを入れたところ、IE/Netscape 6以降/Mozilla 1.1以降、の3つに導入するか、と聞いてきて、Mozillaでも無事にJava 1.4.2が使えました。
# Phoenixは大丈夫かなぁ...

matsuさん、ありがとうございました。

なお、IEについては、1.4.1_02ではインターネットオプションにSun Javaを使うかどうかの設定が作られたのに、1.4.2ベータではそれがなく、コントロールパネルのJava PluginでIEのプラグインを有効にしようとすると、権限がないとか言われて有効にできませんでした。
せっかくMSのVMを殺してSunのJavaを強制的に使わせているのに、できなくなっちゃって残念(^^)

Re[7]: Re: 便乗質問(1.4.2ベータはMozillaでもOK)
(#5475) このトピック中17番目の投稿

>>1.4.2では、mozilla1.1以降という項目がでてきました。
>
> そういうことですか。
> Javaプラグインの制御が、Netscape(Mozilla 1.0)とMozillaで分けられたんですね。
なるほど、私もいわれて気がつきました。netscape6系とそれ以後ということですね。

> 私が入れた時は、MozillaはZIP版しかなくて、Netscape 7だけの状態でした。
私も一度だけ、ZIP版を入れたことがあります。
なんとかEmbedとかいうプログラムを実行したらものすごく動作が軽くて
Geckoだけならどうのこうのという議論があったのはこういうことか、と
しみじみ思いました。
ふつうのmozillaのprefs.jsとかをつかって??Embed.exeをうごかせば、
GUI以外(XUL以外?)の、セキュリティとかの設定は有効になるのでしょうか?
だとしたら、その方が使いやすかったりして…ともじら使いにあるまじき
よこしまな心が芽生えてしまいます。

> なお、IEについては、1.4.1_02ではインターネットオプションにSun Javaを使うか
>どうかの設定が作られたのに、1.4.2ベータではそれがなく、コントロールパネルの
>Java PluginでIEのプラグインを有効にしようとすると、権限がないとか言われて
>有効にできませんでした。
> せっかくMSのVMを殺してSunのJavaを強制的に使わせているのに、できなくなっちゃって残念(^^)

私のところはもっとひどいです。1.4.1_02の項目はでてチェックが入っている
にもかかわらず、Sun javaが使えません。うちはMS javaが入ってない
(winで認識されていないか有効になっていない)のでjava仮想マシンを
ダウンロードしろと文句を言ってきます。
winからIE4,5を一度切り離して、その上でIE6をいれたので動作はすこぶる快適です。
javaを使うときはmozillaを使えば問題ないので気にはしていませんが。
またレジストリをいじるか……
MS javaより遅い本家Sun javaもようやくそのイメージが払拭されそうなのに、
こういうところでMS javaを除去できないためにSun javaが普及しないのは
残念です。
MS javaみたいにWindows上でJavaVMが起動時からとけ込むように実行されていて、
その上でアプリケーションもアプレットも動けば、かなり速くなると思います。
ひとつひとつが別のjavaVM上で動くことはセキュリティの観点からも重要なのだろう
とはおもいますが、もっと普及するためにやってほしいところです。


[ 前のトピック内容10件 ]
このトピックの全ページ / [0] [1]

返信不可


- Child Tree -