ツリー一括表示
Message Flashで前回の再生残像が残るバグ /治療してもらおうか? (14/12/27(Sat) 01:16) (#58352)
LMessage Re: Flashで前回の再生残像が残るバグ /maji (14/12/28(Sun) 18:24) (#58353)
|-Message Re: Flashで前回の再生残像が残るバグ /残像が残るのは新規タブ (14/12/29(Mon) 13:10) (#58354)
LMessage Re: Flashで前回の再生残像が残るバグ /残像が残る手順 (14/12/29(Mon) 13:22) (#58355)
LMessage Re: Flashで前回の再生残像が残るバグ /pal (14/12/29(Mon) 14:02) (#58356)
|-Message Re: Flashで前回の再生残像が残るバグ /残像が残る手順 (14/12/29(Mon) 14:39) (#58357)
LMessage Re: Flashで前回の再生残像が残るバグ /残像が残る手順と他 (14/12/29(Mon) 14:52) (#58358)
|-Message Re: Flashで前回の再生残像が残るバグ /のらねこ (14/12/30(Tue) 05:41) (#58361)
LMessage Re: Flashで前回の再生残像が残るバグ /maji (14/12/30(Tue) 10:10) (#58365)
LMessage Re: Flashで前回の再生残像が残るバグ /のらねこ (14/12/30(Tue) 13:55) (#58367)
LMessage Re: Flashで前回の再生残像が残るバグ /maji (14/12/31(Wed) 22:06) (#58384)
LMessage Re: Flashで前回の再生残像が残るバグ /maji (15/10/11(Sun) 17:30) (#58613)


Flashで前回の再生残像が残るバグ
(#58352) 親階層
治療してもらおうか? の投稿 : 2014/12/27(Sat) 01:16:10
(環境: WinVista/Other)

このようなFlashを再生して再度再生すると前回の残像が見えてしまうバグ
http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E6%9C%80%E8%BF%91%E3%81%AE%E3%83%96%E3%83%A9%E3%82%A6%E3%82%B6%E3%81%AF%0A%E7%97%85%E7%9A%84%E3%83%AC%E3%83%99%E3%83%AB%E3%83%BB%E3%83%BB%E3%83%BB%0A%E3%81%9D%E3%82%8D%E3%81%9D%E3%82%8D%E6%B2%BB%E7%99%82%E3%81%97%E3%81%A6%0A%E3%82%82%E3%82%89%E3%81%8A%E3%81%86%E3%81%98%E3%82%83%E3%81%AA%E3%81%84%E3%81%8B%EF%BC%81&fnt=3

[メール転送/OFF] / 返信

(環境: WinNT/Other)

#58352 の 治療してもらおうか? さん(投稿:2014/12/27(Sat)01:16:10,環境:WinVista/Other)
maji と申します。

タイトルに「 Flashで前回の再生残像が残るバグ 」と記されていますが
当方では「Flashで前回の再生残像が残る」現象は再現しません。

不思議ですね。

ちなみに当方の環境は

Windows 8.1 Pro
Firefox 34.0.5
Shockwave Flash 16.0.0.235

です。
新規プロファイルを作りテストしています。

質問(1)
治療してもらおうか? さんの環境(各種アプリのバージョン)を記載ください。

質問(2)
治療してもらおうか? さんがバグ体験された操作手順を記載ください。
同じ操作にて再現テストを試みます。

-----

なお
治療してもらおうか? さん指定された再生データが長く冗長なので
私の手元では次の短いバージョンでテストしています。
長いものでも短いものでも再現しないのは変わらなかったので。

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E5%86%8D%E7%8F%BE%E6%80%A7%0A%E3%83%86%E3%82%B9%E3%83%88%E4%B8%AD%EF%BC%81&fnt=3

-----

では。



.

[メール転送/OFF] / [親58352] 返信

(環境: WinVista/Other)

>タイトルに「 Flashで前回の再生残像が残るバグ 」と記されていますが
>当方では「Flashで前回の再生残像が残る」現象は再現しません。

GPUやメモリなどスペックの余裕によって
スピードが変わるかもしれませんが、
リンクから新規ウインドウでは残像が残りません。

残像が残るのは新規タブや[F5]リロードによるものです。
リロードの場合embed枠を再利用するらしい。

そのembed枠をレイヤー再構成する前に
前回の表示を背景色で瞬間的にクリアすると
残像が見えなくなると思われる。

環境
Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0 Width/1440px Screen/1920px

手順
以下をランダムに新規タブで表示すると残像が判りやすいかも?

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A1&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A2&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A3&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E5%86%8D%E7%8F%BE%E6%80%A7%0A%E3%83%86%E3%82%B9%E3%83%88%E4%B8%AD%EF%BC%81&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E6%9C%80%E8%BF%91%E3%81%AE%E3%83%96%E3%83%A9%E3%82%A6%E3%82%B6%E3%81%AF%0A%E7%97%85%E7%9A%84%E3%83%AC%E3%83%99%E3%83%AB%E3%83%BB%E3%83%BB%E3%83%BB%0A%E3%81%9D%E3%82%8D%E3%81%9D%E3%82%8D%E6%B2%BB%E7%99%82%E3%81%97%E3%81%A6%0A%E3%82%82%E3%82%89%E3%81%8A%E3%81%86%E3%81%98%E3%82%83%E3%81%AA%E3%81%84%E3%81%8B%EF%BC%81&fnt=3

[メール転送/OFF] / [親58352] 返信

(環境: WinVista/Other)

一部訂正

>タイトルに「 Flashで前回の再生残像が残るバグ 」と記されていますが
>当方では「Flashで前回の再生残像が残る」現象は再現しません。

GPUやメモリなどスペックの余裕によって
スピードが変わるかもしれません。
残像が残るのは[F5]リロードや新規タブ、
新規ウインドウでも残像が残りました。
embed枠を再利用するらしい。

そのembed枠をレイヤー再構成する前に
前回の表示を背景色で瞬間的にクリアすると
残像が見えなくなると思われる。

環境
Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0 Width/1440px Screen/1920px

手順
以下をランダムに新規タブで表示すると残像が判りやすいかも?

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A1&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A2&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%EF%BC%A3&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E5%86%8D%E7%8F%BE%E6%80%A7%0A%E3%83%86%E3%82%B9%E3%83%88%E4%B8%AD%EF%BC%81&fnt=3

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E6%9C%80%E8%BF%91%E3%81%AE%E3%83%96%E3%83%A9%E3%82%A6%E3%82%B6%E3%81%AF%0A%E7%97%85%E7%9A%84%E3%83%AC%E3%83%99%E3%83%AB%E3%83%BB%E3%83%BB%E3%83%BB%0A%E3%81%9D%E3%82%8D%E3%81%9D%E3%82%8D%E6%B2%BB%E7%99%82%E3%81%97%E3%81%A6%0A%E3%82%82%E3%82%89%E3%81%8A%E3%81%86%E3%81%98%E3%82%83%E3%81%AA%E3%81%84%E3%81%8B%EF%BC%81&fnt=3

[メール転送/OFF] / [親58352] 返信

(環境: Win 7/Other)

> 環境
> Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0 Width/1440px Screen/1920px
>


36のバグかもしれませんが、Firefox 34.0.5では問題ないように思います。

それから、念のため。
ご利用のFlashのバージョンは?
Flashの保護モードのON/OFFは?


当方環境
Mozilla/5.0 (Windows NT 6.1; rv:34.0) Gecko/20100101 Firefox/34.0
Flash : 16.0.0.235
保護モード:OFF

[メール転送/OFF] / [親58352] 返信

(環境: WinVista/Other)

> それから、念のため。
> ご利用のFlashのバージョンは?
> Flashの保護モードのON/OFFは?

Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0
https://www.mozilla.org/ja/firefox/developer/

Flash You have version 16,0,0,235 installed
http://www.adobe.com/jp/software/flash/about/

ProtectedMode=0 未設定
C:\Windows\System32\Macromed\Flash\mms.cfg

[メール転送/OFF] / [親58352] 返信

(環境: WinVista/Other)

一部追加

> 36のバグかもしれませんが、
> Firefox 34.0.5では問題ないように思います。

JSなどの描画スピードが速くなって
Flash画面初期化が取り残された?
非同期タイミングを同期化させる対応?

> それから、念のため。
> ご利用のFlashのバージョンは?
> Flashの保護モードのON/OFFは?

Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0
https://www.mozilla.org/ja/firefox/developer/

Flash You have version 16,0,0,235 installed
http://www.adobe.com/jp/software/flash/about/

ProtectedMode=0 未設定
C:\Windows\System32\Macromed\Flash\mms.cfg

[メール転送/OFF] / [親58352] 返信

(環境: WinNT/Other)

わかっていると思いますが、今の段階では、Firefox36は開発者向けに
リリースされています。もう少し開発にコミットできる方向でテストを

>>36のバグかもしれませんが、
>>Firefox 34.0.5では問題ないように思います。
>
> JSなどの描画スピードが速くなって
> Flash画面初期化が取り残された?
> 非同期タイミングを同期化させる対応?

Firefox34や35では問題ないか、確認してもらえますか?
それと、新規プロファイルで再現しないか確認してもらえますか?

https://bugzilla.mozilla.org/show_bug.cgi?id=1097321
という話もあるので、35から環境依存で不具合が発生しているという場合
もありそうです。

それと JavaScript関係ないでしょ、Flash なんだから。

[メール転送/OFF] / [親58352] 返信

(環境: WinNT/Other)

#58358 の 残像が残る手順と他 さん(投稿:2014/12/29(Mon)14:52:12,環境:WinVista/Other)
maji です。


その後のテスト状況です。
結論は「私の手元では再現しない」です。


-----(ここから)

テストに使った URLは以下のもの。

http://www.geocities.jp/korowinu/lupin3rd.swf?msg=%E5%86%8D%E7%8F%BE%E6%80%A7%0A%E3%83%86%E3%82%B9%E3%83%88%E4%B8%AD%EF%BC%81&fnt=3

上記をクリックし上記を同じタブの中でいったん動かします。

1) 動き終わった状態(→黒い背景の画面に指定した文字列が白抜き文字で表示されてる)で
  リロードボタン(?)を押す。

2) 一瞬(←視認できない(Win版 Firfoxだとほとんど判らない)くらいの一瞬)
  画面が白くなり(★)すぐに黒い画面にかわる。

3) その黒い画面に所定の文字列が順番に表示される。
  最後に指定した文字列が全て画面中央に並んだ状態で止まる(→で終わる)。

4) 2)〜3)を繰り返す。

たぶん推測ですが、、、
上記 1) の画面で残っていた文字列が
上記 2) の一瞬画面が白くなった時点かその直後の画面が黒くなった時点にて
残像として残っているのだと思います。

注:★印で記した「視認できないくらいの一瞬」画面が白くなるのは
  Windowsパソコンではなく
  ケータイだとか Androidタブレットだとか比較的に遅いデバイスだと
  視認確認できます。

-----(ここまで)

以上のテストを何回やっても問題の現象は手元では再現しません。

環境は
 Windows 8.1 Pro
 Firefox 34.0.5
 Shockwave Flash 16.0.0.235
 ProtectedMode=0 未設定(→ C:\Windows\System32\Macromed\Flash\mms.cfg)
です。

pal さんからは (#58356) で

> 36のバグかもしれませんが、

とコメントあったので
開発版「 36.0a2 (2014-12-29) 」でやってみましたが再現しませんでした。
当然ながら
通常版の 34 と 開発版の 36 ではプロファイルを切り替えテストしています。

さらに
別の Windows7 パソコンの Firefox 通常版(34) でもやりましたが
問題の現象は再現しませんでした。

以上、
複数の環境でトライしましたが「私の手元では再現しない」です。

-----

私の手元では
Win8.1 の Firefox通常版(34)でも開発版(36)でも問題無し
他の Win7(sp1)での Firefox通常版(34)でも問題は無しですし、
pal さんの方でも問題再現してないとの事です。

なんとなくですが今回のバグは
のらねこ さんアドバイスの 35 でのバグの話もありますが
私には
#58358 の 残像が残る手順と他 さんのみの環境で起こるバグ
と見えています。
ただし
ソレが何に起因するか私には判りません(←私の手元では再現しないので)。

-----

とは言いつつも切り分けはしたいので
#58358 の 残像が残る手順と他 さんに質問です。


質問(3) 再現手順について。

現象の再現手順は上述の (ここから) 〜 (ここまで) の間の手順で
間違いは無いですか???


質問(4) Firefox開発版バージョンについて。

> Mozilla/5.0 (Windows NT 6.0; rv:36.0) Gecko/20100101 Firefox/36.0
> https://www.mozilla.org/ja/firefox/developer/

バージンは正確に記載ください。
ちなみに当方の場合は上述した通り

36.0a2 (2014-12-29)

です。


質問(5) 新規プロファイル 及び 通常版(34) での確認について。

のらねこ さんからもアドバイスありますが

・新規プロファイルでの確認
・通常版(34)(またはベータ版(35))での確認

をお願いします。


質問(6) 他ブラウザ再現について。

Firefoxでは無い他のブラウザ(→ Microsoft の IE とか Google の Chrome とか )
でテストしたらどうなりますか???


-----


では。



.

[メール転送/OFF] / [親58352] 返信

(環境: WinNT/Other)

> 質問(6) 他ブラウザ再現について。
> Firefoxでは無い他のブラウザ(→ Microsoft の IE とか Google の Chrome とか )
> でテストしたらどうなりますか???

今、NPAPI 使ってるブラウザって Gecko エンジン以外ありましたっけ?
Chrome はデフォルト PPAPI になってると記憶しているので、PPAPI 無効
にして NPAPI 使うようにしないと、NPAPI Flash での比較はできないですね。
Firefox NPAPI, IE ActiveX, Chrome PPAPI(デフォルト), Chrome NPAPI(PPAPI無効)
とかでテストしてもらうとよいのかな?

[メール転送/OFF] / [親58352] 返信

(環境: WinNT/Other)

#58367 の のらねこ さん(投稿:2014/12/30(Tue)13:55:31,環境:WinNT/Other)
maji です。


> 今、NPAPI 使ってるブラウザって Gecko エンジン以外ありましたっけ?
> Chrome はデフォルト PPAPI になってると記憶しているので、PPAPI 無効
> にして NPAPI 使うようにしないと、NPAPI Flash での比較はできないですね。
> Firefox NPAPI, IE ActiveX, Chrome PPAPI(デフォルト), Chrome NPAPI(PPAPI無効)
> とかでテストしてもらうとよいのかな?

NPAPI か PPAPI かまでは思いが至りませんてせした。
目からウロコ、です。

今は

・本スレッド初投稿者さんの環境で「のみ」バグ出ていて
・私(maji)含め他者では問題は再現されていない

てな状況なので、
ここは本スレッド初投稿者さんに
Firefox通常版(34)や新規プロファイルでの確認や
各種パターンでの確認切り分けをしていただけないと、
そして
バグってるケースとバグってないケースを再現可能な形で整理しないと、
そして私(maji)含め他者で現象を再現出来ないと
先へ進めない様に思います。

NPAPI か PPAPI かが切り分けキーワードと判ればソレは重要なポイントとなり
どこのバグかを含め検討が先へ進めれるのでは、と思います。

とゆ事で
ころころと名前の変わる本スレッド初投稿者さんの確認投稿町ですね。

では。


.

[メール転送/OFF] / [親58352] 返信

(環境: WinNT/Other)

古い記事ですが誤字あったので訂正しておきます。

-----

誤》 ころころと名前の変わる本スレッド初投稿者さんの確認投稿町ですね。

正》 ころころと名前の変わる本スレッド初投稿者さんの確認投稿待ちですね。

-----

では。

.

[メール転送/OFF] / [親58352] 返信
- Child Tree -